Create Replica Failed

12609
27
Jump to solution
03-21-2014 06:46 AM
TysonJohnston
Occasional Contributor
We are in the early stages of testing Collector 10.2.2 on iOS 7.1.

It was a bummer to learn that offline editing cannot be done with versioned datasets (We use the "Create Local Copy for Editing" from a feature service desktop editing model).

The ArcSDE/SQL Server geodatabase which our data is based on is versioned. We created a two-way replica and unregistered the data so it was no longer versioned in the replica, then enabled archiving. We published a service with "Sync" enabled and set up the map on ArcGIS Online.

On the mobile device, the map will download about 3/4 of the way and fail saying that "The operation couldn't be completed. Failed to create replica. Editor tracking fields must be visible. Failed to create replica. Editor tracking fields must be visible." We fixed this issue and republished the service on which the map is based.

Now, we just get the error "Failed to create replica."

Any ideas?
Tags (2)
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor
If you are publishing to a 10.2.1 server its a 10.2.1 service. Sync was in that release but there are necessary fixes in 10.2.2 that are not in 10.2.1 and could be why the Collector is failing to take it offline. Have you tried making a hosted service version and see if the app can take it offline?

Russ

View solution in original post

27 Replies
RussellRoberts1
Esri Frequent Contributor
I am not sure exactly why it would be failing without getting a chance to inspect the service but in the 10.2.2 version of Collector we are only supporting sync with 10.2.2 feature services or hosted feature services. Have you been able to create a replica from the REST endpoint of the service?

Thanks
Russ
TysonJohnston
Occasional Contributor
I am assuming it is a 10.2.2 service as we have the option to enable Sync when publishing the feature service.  ArcGIS Server is at 10.2.1 though, that is the latest available?  I was able to create a local copy for editing of the feature service, the entire extent, without a problem.
RussellRoberts1
Esri Frequent Contributor
If you are publishing to a 10.2.1 server its a 10.2.1 service. Sync was in that release but there are necessary fixes in 10.2.2 that are not in 10.2.1 and could be why the Collector is failing to take it offline. Have you tried making a hosted service version and see if the app can take it offline?

Russ
TysonJohnston
Occasional Contributor
If you are publishing to a 10.2.1 server its a 10.2.1 service. Sync was in that release but there are necessary fixes in 10.2.2 that are not in 10.2.1 and could be why the Collector is failing to take it offline. Have you tried making a hosted service version and see if the app can take it offline?

Russ


That is what I was afraid of.  When will 10.2.2 Server be available?  So, today, the only option for anyone using Collector is a Hosted Feature Service on AGO?
RussellRoberts1
Esri Frequent Contributor
yes right now hosted services will work and the Esri basemaps. April 10.2.2 should be out and you can use your on premise feature services with sync enabled and tiled map services with export tiles enabled.

Russ
CodySelf
New Contributor
Any update on this?  It appears 10.2.2 is still not available correct?
RussellRoberts1
Esri Frequent Contributor
10.2.2 Server is released. Read more about it here

Also in the post is a link to a tutorial video that outlines the workflow for setting up your server data for offline here

Russ
KarenFolger
Occasional Contributor II

I have 10.2.2 server and a 10.2.2 geodatabase with the feature service on a non-versioned feature class.  I'm still getting the Failed to Create Replica message - it doesn't tell me anything else.  I'm using a Tile package that I created and used very nicely in ArcGIS Mobile for Windows.

I was getting a error about Nulls until I took out the other layer in the map which was only Read only vector layer for info. Kinda buggy still!

NicolasGIS
Regular Contributor

Hello,

I had the same issue and I found out that you cannot desactivate a field with index (the ones that have a star at the end in the attribute table).

Though they are not mandatory fields, as soon as they have an index, it will fail.

Hope this can help,

Nicolas