Collector Sync Failure - Dangling Relationships

152
0
07-06-2020 09:46 AM
MollyFoley
Regular Contributor

I have a field tech who physically is states away so I can't exactly look at his hardware, but they reported to me that they received a generic "failed to synchronize edits" message, tried again, and it worked and they did not receive an error message the second time... however I checked our DB and half the data that was supposed to sync is missing. The type of data being synced is two related point layers, e.g. the tech collected an origin point and then collected a bunch of related points (observations) tied to the "origin" by an automatically generated ID as in a 1:M relationship. It successfully synced all of the origin points but none of their related observations. I went into our server logs and saw these error messages, suggesting that the related points never had the origin ID tied to them which should be impossible when collecting with Collector. You cannot add related points without first having an origin point when using related feature services in Collector to my knowledge. 

Will those observations still be salvageable by getting the runtime GDB off the phone or did it erase them from local storage when the second sync finished without error? How can I avoid issues like these in the future?

We are still using Collector Classic.

0 Kudos
0 Replies