Collector Crashing when using Trimble RTX Service

876
10
09-27-2017 12:39 PM
JeffBishop1
New Contributor II

Since the new app upgrades in both Collector and GNSS Status, the Collector app is crashing when the user attempts to open a map. If we switch to SBAS, Uncorrected or Integrated Receiver things are fine. Anyone else seeing this? From ESRI is this a known issue? 

0 Kudos
10 Replies
DougMorgenthaler
Esri Regular Contributor

Hi Jeff-

This is not an issue we are aware of.  A new update of GNSS Status was just released (version 3.0.1).  Can you confirm which version of GNSS Status you've been experiencing these issues on?

0 Kudos
JeffBishop1
New Contributor II

So we tried that and it is still crashing.

0 Kudos
DanColbert
New Contributor III

Hi Jeff -

In addition to the version of GNSS Status you're using, it'd be great to know which receiver (R1 or R2) and which level of RTX service is being used as well.

Thanks!

0 Kudos
JeffBishop1
New Contributor II

R1

0 Kudos
RobertHarris5
New Contributor III

Please keep us posted on this status. We just ordered a Trimble R2 unit and  the FieldPoint RTX service so we are very interested in how this turns out. We should have the unit in the next few days.

0 Kudos
by Anonymous User
Not applicable

When I first set up the Trimble with RTX, I could see the crashing behavior, but switching to SBAS, then switching back alleviated the problem. 

JeffBishop1
New Contributor II

Latest from ESRI below. It is officially a bug at this point with workarounds.

The crashing seems to be unique to when using RTX (Any) + SBAS correction sources via the GNSS Status app.

 

When using RTX (Internet) or RTX (Satellite) + SBAS corrections via GNSS Status, the issue isn’t reproducible.

When using RTX (Any) + Uncorrected via GNSS Status, the issue isn’t reproducible.

 

We’re still investigating this issue further, however for the time being, please continue using the previous workaround that Dan provided or the combinations that I mentioned above via GNSS Status.

by Anonymous User
Not applicable

The following bug was logged with Esri Support:

BUG-000108426 : Collector for ArcGIS (iOS) will crash while opening a web map if a Trimble R1 utilizing RTX corrections is set as the location provider in Collector.

0 Kudos
MichaelWalker
New Contributor

I have the same issue as Jeff here. 

Some slight differences in my collection set-up but I suspect the same bug is causing the crash when trying to use Collector application for ArcGIS (iOS).   

I have a Trimble R2 receiver, using Trimble CenterPoint RTX for correction service. I've been using this system for 10 months and Collector has been working great until my iPad ran updates on both Collector for ArcGIS and GNSS Status applications sometime during the middle of last week (estimated date - 9/27/17).

As you probably already know, this bug seems to be isolated to iOS. I ran this set-up on my Android phone which uses Android 7.0 and it works perfectly (with the latest Collector for ArcGIS and GNSS Status applications installed, however they might be different versions I imagine).

0 Kudos