Select to view content in your preferred language

Cannot View or Add Related Records in Collector/FieldMaps

790
1
Jump to solution
01-05-2023 07:02 AM
StormwaterAdmin
New Contributor III

Hello!

I have a web map that a colleague created on ArcGIS Online several years ago and has been working well in Collector until recently. It contains a feature layer with a related table. In the web map on ArcGIS Online, I am able to see the related table and which records are related to the record in the feature layer, so I know the relationship between the 2 is still working. However, when I open the web map in Collector or FieldMaps I am unable to see the related records. I am also unable to add new related records. In Field Maps when I select a feature and go to related records none of them appear, and when I try to add a new one it says "form contains unsupported data". In Collector it says "unable to create feature".

Any help with this would be greatly appreciated!

0 Kudos
1 Solution

Accepted Solutions
StormwaterAdmin
New Contributor III

I was able to come up with a solution. My related tables did not have a GUID and the relationship was based on an asset name. So I added a GUID field to the related table and made it the Foreign Key (Parent Key is GlobalID of the feature layer). I republished the service and it is working again.

View solution in original post

0 Kudos
1 Reply
StormwaterAdmin
New Contributor III

I was able to come up with a solution. My related tables did not have a GUID and the relationship was based on an asset name. So I added a GUID field to the related table and made it the Foreign Key (Parent Key is GlobalID of the feature layer). I republished the service and it is working again.

0 Kudos