Apparent Bug: Collector 17.0.3 Android unable to edit offline feature attributes

Jump to solution
10-23-2017 03:37 PM
New Contributor III

I believe I've found a bug with the latest Android release of Collector (17.0.3). The symptoms are that a user is unable to edit attributes for a feature class when using an offline map. There is no error presented to the user within the app. The edits simply aren't stored. This is on a Feature Layer hosted on ArcGIS Online (AGOL), using an enterprise account.

I believe the minimum requirements to reproduce the bug are:

  • Collector for ArcGIS 17.0.3, Android (released Oct 17, 2017)
  • Feature Layer (hosted) on AGOL used in Web Map; editing and syncing enabled on layer
  • Web Map using said layer with offline mode enabled
  • Web Map downloaded to device for offline use
  • Editing - What kind of editing is allowed?: Only update feature attributes

The last option seems to be the kicker. The map works correctly in Collector with that option set under the following circumstances:

  • Map is not downloaded; used online in Collector (Android)
  • Map used on iOS device

Changing the option to Add, update, and delete features results in a working offline map in Collector 17.0.3 Android.

We also happened to have a few tablets that are used infrequently and thus hadn't received the update to 17.0.3 yet. Those devices, using 17.0.2, are able to edit the attributes while the Editing option is set to Only update feature attributes.

Using the full edit capability is less than ideal for our use case. Our users are updating feature attributes for parcels. Allowing the full editing capabilities means they could change the geometry of the parcels, or, worse, inadvertently delete them. They also do not have connectivity while in the field to simply work around the issue by using the maps in online mode.

I've also tested this on both Android 7.1 and 8.0.0 with the same results.

I'm happy to provide any additional information if it helps confirm or fix this bug.

17 Replies
New Contributor

Is there already an update when this issue is fixed? The people in our organisation are dependent on working with the collector offline mode and updating features offline, and now they can not show their progress in the field. 

Esri Regular Contributor

Hi Gebruiker-

Apologize for inconvenience this has caused.  We are working on an update slated for release this week to resolve this issue.

New Contributor II

With the last update (17.0.4) the problem seems solved, thank you!

0 Kudos
New Contributor III

Only a partial fix.

Works for area that are already downloaded when 17.0.4 gets installed, but any areas downloaded after the upgrade have the same issue as in 17.0.3.

The only difference being the user now gets an error message indicating Collector was unable to update the feature (applies to attributes of all existing features, related records or attachments while offline), vs 17.0.3 where there was no error message.

0 Kudos
Esri Regular Contributor


Can you force close the app and open again to see if the issue still happens?  This seems to be similar to BUG-000090504. 


0 Kudos
New Contributor III

This seems to have done the trick.


New Contributor III

17.0.4 appears to be fully working for us. Thanks Doug Morgenthaler and Bethany Berry!

Deb McIlwrath I'm not seeing the same symptoms as you with 17.0.4. I've removed and downloaded my maps a couple of times now and they are working. I've edited feature attributes, attached photos to the features, and created related records in a table. I haven't tried editing any existing related records in said table though.

The only difference that's not clear to me is, are these downloads completely new on the devices you're using? In my tests, I did just remove an existing map and re-download it.

0 Kudos
Esri Regular Contributor

Joseph, thanks for sharing the result. During in-house testing, we have seen it but it doesn't happen every time. 

0 Kudos