Unknown textures when applying rules

3276
10
Jump to solution
07-08-2015 12:20 PM
awei
by
New Contributor III

Hey all,

When I tried to assign street with Esri rule files. All my streets show "unknown textures" I have no idea why. Anybody knows?

Reply
0 Kudos
1 Solution

Accepted Solutions
umarmakdoom
New Contributor

try to copy the "assets" folder from the original project which has the rule in it and paste it in your project in the same name of the folder "assets"

View solution in original post

10 Replies
ChrisWilkins
Regular Contributor

If you open the rule, and search for file paths or images, such as ".jpg", you can find the path to the textures, and match those to where your texture files are. OR, you might realize you don't have the texture files.

awei
by
New Contributor III

Thanks Chris that's helpful. However I still get this dark spot and dark lines in my streets. I don't see these on the tutorial video. Are they normal?

Reply
0 Kudos
MicahTaylor
Occasional Contributor III

Is that screen shot from the CityEngine viewport?  If so, it looks like you have the graph network turned on.  Try turning the graph network off from the toolbar at the top and see if that removes the black lines.

awei
by
New Contributor III

But without Network it only shows like this

Reply
0 Kudos
DavidWasserman
Regular Contributor

Micah is referring to this network toggle button, not the Scene Layer.

The CE Documentation has a special section on the View Port toggles and buttons for more information.

David Wasserman, AICP
DavidWasserman
Regular Contributor

Micah is correct, the points are a result of the segment network layer being turned on. You only want to show polygon models when showing street segments. Those points will appear  in screen shots as well if you take them unless the segment lines are toggled off in the display.

Also judging by the number of breakpoints, your network might benefit from a simplify graph run.

David Wasserman, AICP
ChrisWilkins
Regular Contributor

you can also turn the street network layer off using the 2nd of the 4 layer toggles at top of viewport

Reply
0 Kudos
awei
by
New Contributor III

Thank you for telling me to turn off the graph network. After that they look like this, how am I going to remove those black lines?

Reply
0 Kudos
DavidWasserman
Regular Contributor

Hello again!,

You want to turn off wireframe on Shaded/Textured.

David Wasserman, AICP
Reply
0 Kudos