Transparent terrain in web viewer

2902
9
07-15-2013 05:24 AM
CarlBester
New Contributor
Hi,

Does anybody know if it is possible to keep the terrain layer's transparency when exporting to a web viewer?

For instance I set the terrain layer's transparency to 0.5, but when I open the web viewer it has lost all transparency. Are there any export settings that I am missing?

Thanks,

Carl
0 Kudos
9 Replies
MatthiasBuehler1
Frequent Contributor II
Hi Carl,

That's a missing feature.

Try a texture layer with a transparent texture, ok ?

M.
0 Kudos
CarlBester
New Contributor
Hi Matt,

I've tried the texture as well but still it doesn't inherit the transparency when exported.

Do you think this might become an added feature in future releases?

Thanks

See the pictures below:

[ATTACH=CONFIG]25992[/ATTACH]

[ATTACH=CONFIG]25993[/ATTACH]
0 Kudos
CarlBester
New Contributor
Also, is there a way to present the scene's light settings so that the web viewer opens up at a specific time and season? For instance 8:15 am in Fall?

Regards,

Carl
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,


we'll track the transparency thing down. Thanks for reporting this.

concerning the time / date setting of a WebScene, that's more work and may only be possible to customize once the API is available. But as mentioned in an other thread, that will take some time.


Hope you can still work without those features for now..

Matt
0 Kudos
YigalMuntner
New Contributor III
Hi Matt,

I have also transparency and renderer problems. I have a TIN layer with symbology and transparancy defined in ArcScene.
It is being exported as a non transparent and green symbol layer.


Regards,
Yigal Muntner
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi Yigal,


Can you try with the newest patch ?
http://support.esri.com/en/downloads/patches-servicepacks/view/productid/66/metaid/2027

Let me know ..

Matt
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi, here's an other answer by Michael Lau from Redlands:

( thanks Michael )

Hi Matthias,

Currently TIN layers are exported as green and non-transparent by the �??Export to 3D Web Scene�?� geoprocessing tool.  TIN layer symbology is not supported, and the patch does not fix this limitation.  The user�??s issue from forum posting below can be worked around by first converting the TIN to a 3D polygon feature class. 

In ArcScene 10.2 updated with patch*:
  1. From ArcToolbox navigate to and open the �??TIN Triangle�?� GP tool from the 3D Analyst Tools>Conversion>From TIN toolset.
  2. Input the TIN and run the �??TIN Triangle�?� GP tool with default settings.
  3. The output 3D polygon feature class is automatically added to the scene document.
  4. Set the layer color on the new 3D polygon layer in the TOC by clicking on the layer�??s color chip.
  5. Set layer transparency on the layer from the layer properties menu.(right click on layer to open menu)
   (see attached image)
  6.  Remove any extra layers from ArcScene including the original TIN
  7. Export to web scene

*patch: http://support.esri.com/en/downloads/patches-servicepacks/view/productid/160/metaid/2027

[ATTACH=CONFIG]28593[/ATTACH]
0 Kudos
YigalMuntner
New Contributor III
Thanks Guys,

I have installed the patches and followed the steps. It solved the problems.
I can control the renderer and transparency.

Best Regards,
Yigal
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Glad this solved the problem.

Thanks to Michael !


m.
0 Kudos