Problem with Coordinate system in CityEngine

3427
8
11-20-2013 12:31 PM
LucieKoucká
New Contributor
Hi,

I have a problem with importing terrain and shapefile. Both are in coordinate system: S-JTSK Krovak East North. First I imported terrain (.tif) and set the coordinate system. And after that I want to import shapefile with streets. But CityEngine write this error:

The data is located too far from the the current scene's contents. Either edit the (geo-)location of the data, choose an adequate projection, or import it into a new empty CityEngine scene.

Every data are prepared in ArcGIS, where I set the same coordinate system. I tried to import shp as the first, also I tried to set coordinate system to cityengine scene. But still the same.

I tried many ways how to do it and now I don't have any idea. So I'll be grateful for any advice.

Thanks!

Lucka
Tags (2)
0 Kudos
8 Replies
MatthiasBuehler1
Frequent Contributor II
Hi,

importing all elements in separate, empty scenes works ?

m.
0 Kudos
AkiKaapro
Esri Contributor
Hi,

I had this same problem, which has also been reported here: http://forums.arcgis.com/threads/94496-SHP-import-failed-the-data-is-located-too-far...

In my case, the problem was that my DEM's world file information used commas as decimals, while the CityEngine used points. So I switched the commas with points in the world file and after that both the raster and vector data aligned just fine in CityEngine.

I'd guess this is pretty common problem for some European users.

-Aki
0 Kudos
LucieKoucká
New Contributor
Hi,

finally Matthias's advice works. I tried to import terrain (with empty scene) and after shp. But it was the same problem. I looked to world files (where are points :)). In the end I imported shp as the first (empty scene) and after that terrain .. it works. I don't know why, but it works only this way.

So thank you both.

Lucka
0 Kudos
GregorRadlmair
New Contributor III
not only the world files need a point as decimal delimitor, even the raster itself. ArcGIS 10.2 with German language pack honors the system settings while exporting a raster - so you have to switch to a setting with point as dec delimitor first, restart the ArcGIS application and export your raster again.

Gregor
Esri Deutschland
0 Kudos
JOHNESTHER
New Contributor
Hi,

importing all elements in separate, empty scenes works ?

m.


Yes Mathias it works. but how do i make my already created scene be draped over the imported terrain if it is replying this error?
0 Kudos
MatthiasBuehler1
Frequent Contributor II
hi ..


what do you mean by this concisely ?

how do i make my already created scene be draped over the imported terrain
0 Kudos
JOHNESTHER
New Contributor
hi ..


what do you mean by this concisely ?

how do i make my already created scene be draped over the imported terrain


when you say to import the terrain on another scene, how do i make my buildings and streets models to float on the other scene with the terrain so that i can export them as one to city engine web scene.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,


if you exchange the terrain, you need to align your data to the new terrain.

for this, CE has some align tools.

a screenshot would help me to understand what type of data you have and how the terrain looks.


let me know ..

matt
0 Kudos