multipatch import - polygons instead of 3D?

2722
3
02-22-2012 04:26 AM
ChrisHewes
New Contributor II
Hello!

I'm having some trouble importing Multipatch data from ArcScene into CityEngine. I'm using Esri CityEngine 2011.1 build 1021 (trial, win32-64bit). 

I used "Layer 3D to Feature Class" in ArcScene to create multipatch data from polygons with height data. When I import the Multipatch data into CityEngine, it instead shows me 2D polygons. When I run a simple extrusion based on the height attributes, the buildings extrude DOWNWARD. (I can tell CityEngine to extrude NEGATIVE heights and then the appear above the surface, but they're shaded unequally!) [ATTACH=CONFIG]12118[/ATTACH]

If anyone has any advice or can point me in the right direction with further documentation, that would be much appreciated!

Thanks!
0 Kudos
3 Replies
MatthiasBuehler1
Frequent Contributor II
hi !


fyi : this thread may also be of interest for you :
http://forums.arcgis.com/threads/50979-re-model-%E2%80%98non-textured%E2%80%99-3D-feature-class-into...



wait for the new versions 2011.2 which should be released very soon. it should fix a lot of issues.

sometimes, 3d multiPatches lose their z component, thus are flattened out - which is clearly a bug.


1]

what you could do is instead of importing the geometries via multiPatch, import them via kml (which is basically a collada file with location info). make sure you import it (e.g. RMB > import > kml ) NOT as static model. instead, it will be imported as static shapes. the difference is :
static model : as the name states, it's already a 'model' and cannot be changed.
static shape : since the polygons are shapes, you can assign rules and work with those shapes in CGA.


2]
if the buildings extrude downwards, the normal points down. this has to do with the point order (if clockwise or counter clockwise).

thus, you need to fix the normal of the shape. either via Shapes menu > reverseNormals
or in CGA like here :
http://forums.arcgis.com/threads/49789-Reverse-Invert-Lot-Orientation
0 Kudos
ChrisHewes
New Contributor II
Thank you so much for your help! I really appreciate it!The coding for the normals did the trick exactly!

I'm getting the same error from the thread titled "KMZ stuff" when I try to import the KMZ file, so I'm looking forward to the new release!

Thanks again!
0 Kudos
larryzhang
Regular Contributor
On our practice with multipatch import, my comments are put below for your trial:

  1. There is No problem at all to import multipatch SHP within CE 2011.1. Please follow the chain: File/Import/CityEngine Layers/ Shapefile Import. It works.


  1. There may be some issues (or bugs) within the tool "Layer 3D to Feature Class". So, personally, if you want to do it within ArcGIS 10.0 (SP3 & COLLADA patch as well), especially, your multipatch has textures associated, the tool called �??Multipatch To Collada�?� (Conversion) should be used. It works very well for interoperation between CE and ArcGIS

Thank you so much for your help! I really appreciate it!The coding for the normals did the trick exactly!

I'm getting the same error from the thread titled "KMZ stuff" when I try to import the KMZ file, so I'm looking forward to the new release!

Thanks again!
0 Kudos