CityEngine Terrain Map

8671
24
05-29-2013 01:44 AM
AvgiSotiropoulou
New Contributor
Hi, :)

I have some issues in creating a terrain in city engine. I have create a New Scene and add some data from OSM then I follow the
steps that are described in Tutorial 2/Part 1, using as  Heightmap a georeferenced DEM image and as Texture a georeferenced image
from OSM. But, althougn in Arcmap they are correct in CityEngine I receive the following error: The data is located too far from
the current scene's contents. Either edit the (geo-)location of the data, choose an adequate projection, or import it into a new
empty CityEngine scene.

I have done the opposite, to create a New Scene create first the Terrain and add after the data, but I received again
the error above.

I really cant find out what is going wrong
Tags (2)
0 Kudos
24 Replies
by Anonymous User
Not applicable
Without seeing your data I would assume that the georeference on your DEM and your OSM street data are not the same. Try two scenes - one where you import the DEM first, another where you import the OSM first. Then pay attention to where these two scenes are geographically, and if they are the same then that is a problem we can look at. Let us know if these two data are in same or different location, and we can go from there.

Chris
0 Kudos
AvgiSotiropoulou
New Contributor
I tried that but it didn't work :/, I received the same error. Yes the data are all from the same location. It is strange that the data do
overlap in ArcMap, but do not in city engine ..I have attached you the the scene from ArcMap.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi !

Did you get this working ?

Did you check the import tutorials ?

Let me know ..

Matt
0 Kudos
JeffShih
New Contributor III
Make sure that the heightmap is georeferenced. The texture file does not need to be, but it should have the same aspect ratio. When you import the heightmap, leave all the settings default. The min/max elevation, x-size and x-offset should auto populated. DO NOT change any of these values (remove the existing terrain layer first if you've already altered the values prior or it won't auto populate). When you click finish, you may not see anything on the screen, just hit 'A' to frame the extent.
0 Kudos
AvgiSotiropoulou
New Contributor
Hi!!
Thanks a lot for the response :) I finally worked it out!! The terrain map that I was using had a resolution 1653 x 1124 so
I thought that it wouldn't be there the problem. After trying all the possible options, like inserting first the image and
then the data an the other way around and saw that I was still getting an error. I decided to use an image with an even
smaller resolution (849 x 925) and that actually worked! When I am using an image with a resolution smaller than
1000 x 1000 it accepts it.
0 Kudos
JonathonLentine
New Contributor
I'm getting this exact problem, but without any use of Arcmap.  Tried to get OSM data online, used the same exact coordinates to download heightmap data, from several different sources in Geotiff format.

I even opened a larger slice of DEM data up in 3DEM (http://www.visualizationsoftware.com/3dem)  Cropped it to the coordinates and set the coordinate system to the same as the OSM data and it's still giving me this error if it gives me anything at all.

I can get the terrain to show up fine, or I can get the OSM data to show up fine, but not both together.  And they're both set to the same coordinate system (WGS1984 UTM Zone 18N) and lat/lon coordinates.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
hmm.

what's the file sizes ? ( resolutions, actual file size ? )

how much RAM does your graphics card have ?

m.
0 Kudos
JonathonLentine
New Contributor
My memory should definitely not be a problem.  GPU has 2 gigs of memory and system has 8 gigs. 

As for the geotiff and osm data resolution, where could that be found?  They're both of a small area given the same coordinates that I'm using to test out the process of creating a matching heightmap, scene and then exporting them into Unity.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
hi,


can you post the files, maybe that's best to test for me ..

let me know ..

matt
0 Kudos