cityengine exporting issues

3739
3
03-17-2015 12:25 PM
RandiCabezas1
New Contributor

Hey all,

I am having issues exporting the models created using the wizard cities. The export seems to hang at ~70%.... any ideas what could be causing this?

The full setup is as follows:

-create a new wizard city, using small (or medium) size setting and international city rule package.

-generate and select all models

-export them.

The program is still running and I have noticed the memory consumption increases slowly. but even after letting it run for a day it has not finished the export. The scenes are relatively small 500-800k polygons

I've tried exporting in different formats (collada and wavefront obj) and it always hangs.

I've tried various settings regarding the triangulation, handling faces with holes, file export sizes, exporting textures/materials.. etc . but no luck.

There are no errors in the model generation process. There are some warnings however.

Cleaning up the warnings seems to have no impact on this. I eliminated all warnings on one of the scenes but still no luck.

I am using cityEngine 2014.1 on windows 64 bit

Any ideas?

Thanks

3 Replies
YuriPotawsky
New Contributor III

Randi,

After looking over your question, I wanted to pass along a few things.

1. Looks like you are on a 64-bit Win 7 machine. Can you run the "dxdiag" command from the Start Menu and provide the machine specs including CPU, RAM, and GPU specs? I am sure that you are aware that CE requires a minimum of 4GB system RAM.   System Requirements

2. Has the process been attempted when running CE in safe mode? Start-> All Programs->Esri->CityEngine (Safe Mode).

3. You mentioned that memory consumption slowly rises during the exporting process. If you visual inspect the Free memory dialogue within the lower right corner of the CE Viewport, what are those values?

** As Matthias mentioned in an older post these values represent the following:

- left value: JAVA memory

- right value: Native memory (under 64 bit, this value actually shows the rest of the available system memory)

4. If you try to write out the models to File Geodatabase Multipatch are you observing the same behavior?

5. Do smaller model selection sets export without error? This would allow you to determine if the issue is related to large model envelopes which is my suspicion. 

6. Can you send along a screenshot of the model format exporting Dialogue?

Thanks,

Yuri

RandiCabezas1
New Contributor

Hey Yuri,

thanks for the response. See below for answers to your questions.

At this point I am fairly certain this is a bug in the exporting process. In particular the file size restrictions

My export settings are as follows:

wavefront OBJ

export geometry: models

Do not export any terrain layers

One file as long as Memory budget is not exceeded

memory budget 0

Do not merge any meshes

Do not write any vertex normals

Do not write any UVs

Unchecked merge vertices within precision

Checked triangulate meshes

Unchecked include materials

I am able to reproduce the hanging with any combination of the above settings, including different export details, and formats.

The one field that does not produce the error is the memory budget.

According to documentation the 0 in memory budget makes it unlimited, so a single output file is produced.

If instead I place a large value here (say 500Mb) then the export continues without a problem.

The memory consumption increases slowly but steadily according to the task manager roughly a few hundred Kb every couple of seconds (the machine is relatively idle, so I expect this increase is from CE).

2. I did run in safe-mode, had the same issues.

1. see below

------------------

System Information

------------------

Time of this report: 4/10/2015, 14:27:30

   Operating System: Windows 7 Enterprise 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.150202-1526)

           Language: English (Regional Setting: English)

System Manufacturer: Dell Inc.

       System Model: Precision WorkStation T7500 

               BIOS: Phoenix ROM BIOS PLUS Version 1.10 A16

          Processor: Intel(R) Xeon(R) CPU           E5645  @ 2.40GHz (24 CPUs), ~2.4GHz

             Memory: 49152MB RAM

Available OS Memory: 49150MB RAM

          Page File: 14299MB used, 83997MB available

        Windows Dir: C:\Windows

    DirectX Version: DirectX 11

DX Setup Parameters: Not found

   User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

    DWM DPI Scaling: Disabled

     DxDiag Version: 6.01.7601.17514 32bit Unicode

------------

DxDiag Notes

------------

      Display Tab 1: No problems found.

      Display Tab 2: No problems found.

      Display Tab 3: No problems found.

        Sound Tab 1: No problems found.

          Input Tab: No problems found.

--------------------

DirectX Debug Levels

--------------------

Direct3D:    0/4 (retail)

DirectDraw:  0/4 (retail)

DirectInput: 0/5 (retail)

DirectMusic: 0/5 (retail)

DirectPlay:  0/9 (retail)

DirectSound: 0/5 (retail)

DirectShow:  0/6 (retail)

---------------

Display Devices

---------------

          Card name: NVIDIA GeForce GTX TITAN

       Manufacturer: NVIDIA

          Chip type: GeForce GTX TITAN

           DAC type: Integrated RAMDAC

         Device Key: Enum\PCI\VEN_10DE&DEV_1005&SUBSYS_27903842&REV_A1

     Display Memory: 4095 MB

   Dedicated Memory: 3072 MB

      Shared Memory: 1023 MB

       Current Mode: 1920 x 1200 (32 bit) (59Hz)

       Monitor Name: Dell U2412M(Digital)

      Monitor Model: DELL U2412M

         Monitor Id: DELA07A

        Native Mode: 1920 x 1200(p) (59.950Hz)

        Output Type: DVI

        Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um

Driver File Version: 9.18.0013.4788 (English)

     Driver Version: 9.18.13.4788

        DDI Version: 11

       Driver Model: WDDM 1.1

  Driver Attributes: Final Retail

   Driver Date/Size: 3/13/2015 15:41:47, 17258024 bytes

        WHQL Logo'd: n/a

    WHQL Date Stamp: n/a

  Device Identifier: {D7B71E3E-5345-11CF-4649-9D071CC2C435}

          Vendor ID: 0x10DE

          Device ID: 0x1005

          SubSys ID: 0x27903842

        Revision ID: 0x00A1

Driver Strong Name: oem25.inf:NVIDIA_SetA_Devices.NTamd64.6.1:Section035:9.18.13.4788:pci\ven_10de&dev_1005

AlexHasmasan
New Contributor

Hi! I have a problem with exported models (fbx)...i have many folders like Shape, Shape_1, Shape_2, ...

How can i save my project without Shapes folders? Thx!

0 Kudos