City Engine 2016 wont connect to internet through proxy

2256
12
05-19-2017 11:18 AM
AndrewNichols1
New Contributor II

Good Afternoon

I recently installed City Engine 2016 on my computer. I was successfully able to install, and authorize the application but each time I launch it, the opening Wizard (on Example Projects) tells me that “CityEngine was unable to connect to the Web. This error happens if you are not connected to the internet or access the web through a proxy server.”

When I open Edit->Preferences->Network->HTTP Proxy the field for Proxy Script (PAC) was already filled out with a default URL.  I contact my IT department who provided me with another URL, this time for the Proxy Host with a port number 8080. When I apply these changes and restart the application there is no change, I still get the message that “CityEngine was unable to connect to the Web. This error happens if you are not connected to the internet or access the web through a proxy server.”

When I changed the settings I remove the default URL of but when I reopen the CE application this URL has reappeared in the Proxy Script field.

Both of the URL’s my IT department provided have been verified to work.

I would really appreciate any advice you can provide on how I can resolve this issue. I would be happy to provide any more information if required.

Andrew Nichols

GIS Technologist

Geomatics/Mapping Division

City of Peterborough

0 Kudos
12 Replies
ThomasFuchs
Esri Regular Contributor

Thank you for your report. Sorry to hear your trouble.

There is an issue with saving proxy settings in CityEngine 2015.1 and 2016.0.

It has been solved in the CityEngine 2016.1 version, please upgrade to this version.

0 Kudos
AndrewNichols1
New Contributor II

Thanks for replying Thomas

I had already upgraded to 216.1 thinking this might have been the issue. Between my IT department and an ESRI support call we managed to find a work around for the time being. 

0 Kudos
DuliniRatnayake1
New Contributor II

Hi Andrew,

I do have the same problem with CityEngine 2017.1 Concurrent. Do you have any advise for me?

Thank you.

Dulini

0 Kudos
AndrewNichols1
New Contributor II

Hello Dulini

The ticket for this issue is still actually still open and being investigated.

I have had several support calls with ESRI System Architects who have identified the issue as a bug but we have not officially solved the issue. The IT department and myself came up with an in-house work around to bypass the proxy when using CityEngine. 

Sorry I couldn't help more Dulini. When I get a resolution I will post it here!

0 Kudos
DuliniRatnayake1
New Contributor II

No worries. We were able to find a solution. It is the proxy server. Thank you, Andrew. 

0 Kudos
Jean-DanielCIESLAK
New Contributor II

Hi,

Have you find a solution with your proxy server ?

Thanks for your return.

Regards.

0 Kudos
AndrewNichols1
New Contributor II

Morning Jean-Daniel

The proxy settings settings have remained the same. After many discussions with ESRI support and the IT department we came to the conclusion that our proxy server for whatever reason did not talk well to City Engine at all. I had given up for a while but when I saw Thomas's post last month I updated my City Engine and made sure to turn on the "Use TLS 1.2" settings in IE options, then tried again. My "Get Map Data" function now works and I can sign into ArcGis Online fine.  

0 Kudos
DuliniRatnayake
New Contributor III

Hi Jean-Daniel,

As Andrew mentioned I also talked to ESRI support as well a our IT team. Finally we realized need to put your long path for your proxy server.

 

It worked for me.

Regards,

Dulini

0 Kudos
Jean-DanielCIESLAK
New Contributor II

Hi Andrew, Dulini,

 

Thanks a lot for your answers.

My TLS1.2 options are already enabled unfortunately, this corrected the problem for ArcMap 10.x but not for CityEngine 2018.1.

Dulini , what do you mean by "long path for your proxy server" please ?

 

Thanks

0 Kudos