CE crashes on machines with ATI graphics cards

4229
3
11-29-2012 12:27 AM
MatthiasBuehler1
Frequent Contributor II
Dear all.

There's a bug in the ATI graphics driver which crashes the driver, which crashes CityEngie when handling textures with certain very special image resolution ratios.

The crash only occurs when both 'MipMapping' and 'Texture Compression' Rendering options are active, which is the default in CityEngine.


Deactivating one of those 2 options will prevent the crash.

Find them under : Preferences > General > GrammarCore

Since deactivating the Texture Compression will be problematic with datasets that contain many textures, we recommend to deactivate the MipMaps since it only results in a very marginal flickering of the textures in the viewport.
Tags (2)
3 Replies
LixinHuang
Occasional Contributor

We have a Dell Precision Workstation with ATI FirePro V5800. We installed the latest driver. We cannot figure out how to disable MipMapping in the graphic card. We can only adjust Mipmap Detail Level from the tray icon which cannot solve the graphic card driver issue with City Engine. Are there any other ways to do this?

0 Kudos
ThomasFuchs
Esri Regular Contributor

Hello Lixin Huang

'MipMapping' and 'Texture Compression' can be disabled in the CityEngine preferences
(Preferences > General > GrammarCore).

Update: The location has changed to: Preferences >General > Procedural Runtime > Rendering

0 Kudos
ThomasJensen1
New Contributor

It appears that these options are under General > Procedural Runtime > Rendering

0 Kudos