Cannot export models from CityEngine 2014.1

3703
7
12-15-2014 10:22 AM
JosephChimento
New Contributor

Greetings all,

I am hoping that someone can help me troubleshoot this issue.  Simply put, I cannot export models from CityEngine 2014.1.  The Export Models option is available to me, but when I reach the dialogue box that asks you for a model format, all options are greyed out.

I have tried this with Shapes and with static models (objs) and have had no luck.

Has anyone else ever encountered this issue?  If so, how did you remedy it?

Thanks,

JC

Tags (1)
0 Kudos
7 Replies
by Anonymous User
Not applicable

Make sure the models are selected and hit Control-E before leaving the viewport - sometimes if you go into the inspector or other panels in CE, and the viewport is not the active panel then it greys out the option for Export Models.

If this doesn't help, we'll keep looking.

Chris

MatthiasBuehler
Regular Contributor

Hi,

Maybe try reinstalling CityEngine as an other option if the above input doesn't work ..

Let us know if the issue persists..

Matt

Matthias Buehler

Head of 3D Technologies

twitter: @MattB3D

----------------------------------

Garsdale Design Limited

matthias.buehler@garsdaledesign.co.uk

www.garsdaledesign.co.uk

0 Kudos
JosephChimento
New Contributor

Thank you for the suggestions.  I did a full reinstall of 2014.1 and I am still encountering the same issue.

I also tried to use CTRL-E while still in the viewport with the same results.  I can select a model format but the Back, Next, and Finish buttons are still greyed out.

Since a reinstall did not help should I try to wipe out the ESRI folder in my user profile?  It seems like something is persisting even after the reinstall.

Thanks,

Joe

0 Kudos
MathiasBredvei1
New Contributor

I have also experienced this on a customers workstation. Reinstall did not help. There was a lot of error messages in the log window about java-libraries not found after starting CityEngine normally. However, starting CE in safemode helped, and I was able to export the models. Not a permanent fix though, but might help you to get your models out.

Mathias

0 Kudos
JosephChimento
New Contributor

Thank you for the idea of using Safemode, but even that has not solved any of the issues.  In fact, reinstalling CityEngine has actually created more problems.

When starting CE or creating a new project I now get an error " 'Building workspace' has encountered a Prolem. Errors occurred during the build. " The details for the error revolve around instantiating 'org.python.pydev.PyDevBuilder'.  I cannot export any models using "Export Models" or CTRL-E and I cannot open up a Python console window.

This is all very frustrating.  At this point I cannot use CE at all for my workflows.  Using this new information does anyone have an further suggestions?

0 Kudos
PascalMueller
New Contributor III

Sounds like a workspace problem (that I have not yet heard of). Maybe try this:

  1. Rename the folder .CityEngine (in your home directory) as well as your workspace folder (CityEngine?)
  2. Start CE (it should ask to create a new workspace, do it)
  3. Start the CityWizard afterwards.
  4. Export the models >>> please let me know if this works
  5. If so, import your project from the old renamed workspace folder
  6. Open your scene and try to export again >>> please let me know if this works

Our apologies for the caused troubles.

PS: On what OS are you?

0 Kudos
JosephChimento
New Contributor

Just wanted to check in and say that I found the issue and fixed it.

I am on Windows 7.  We use roaming profiles at work and this causes CityEngine to install need files (like all of the Jython libs) to places that are not adjacent to the CityEngine installation.  To fix the issue I created a local user account on my box and used that account to install CityEngine and everything works fine.  Thanks for the suggestions!  You were on the right track with it being a workspace issue.

0 Kudos