Black Snapshot

290
4
02-15-2018 01:30 PM
OdiriOyaide
New Contributor II

I've just downloaded City Engine and am having issues with the  "Save Snapshot ..." tool. Whenever I try to save a snapshot, the resulting image is black with a few things that decide to render. However; the actual models in the viewer look normal.

I'm completely new to City Engine and have no idea what is going on. I've tried playing around with the lighting, but that doesn't seem to make any difference. The image I've attached shows the resulting snapshot.

Unsure if this matters, but I have over 107 warnings in the "show problems" window. This is from just opening the ".cej" scene from the "Tutorial_16_Urban_Planning__2016_1" which is also where the scene in the image is from.

Snapshot showing the black snapshot

City Engine 2017.1.3674

Windows 8.1 64-bit

Intel(R) Core(TM) i5-4590 Processor

8 GB RAM

0 Kudos
4 Replies
DavidWasserman
Regular Contributor

Can you provide more information about your graphics card? I would try editing the view and light settings. 


What happens when you open a blank scene and draw in it? 

David Wasserman, AICP
0 Kudos
Luiz_AmadeuCoutinho
Occasional Contributor III

Give  to us more information about the resolution and format (jpg, png...) you want to export. 8gb ram could be a problem. Or graphic card.

0 Kudos
OdiriOyaide
New Contributor II

Here's what I get when I make a blank scene and make a cube with the polygon tools.Blank scene with cube

Doesn't matter what format I export or the size. This is what I have with a screengrab, so I don't get why the snapshot doesn't work.

Intel(R) HD Graphics 4600

0 Kudos
ThomasFuchs
Esri Regular Contributor

Thank you for reporting the issue.
The CityEngine team has fixed it in the upcoming 2018.0 release.

As a workaround for 2017.1, add this line to the CityEngine.ini file:
-DsnapshotFsaaLevel=0

  • On Windows, the file is located in the installation root folder.
    typically: "C:\Program Files\Esri\CityEngine2017.1\CityEngine.ini"

  • On MacOS it located is inside the application package.
    • First you need to open the application bundle:
      Applications > CityEnigine > Show package contents
    • Second you browse to the file:
      Contents > MacOS > CityEngine.ini