Set proxy for player in qt creator

3580
2
08-10-2015 06:50 AM
Michielvan_Bemmel
New Contributor

Hi Im using beta 3 of appstudio but i cant set my proxy settings in player everytime after a restart the proxysettings are reverted to 127.0.0.1.

Is there a way to pass an argument or set some registery setting or edit a config file so that i can use always a good proxy?

0 Kudos
2 Replies
PaulHaakma
Regular Contributor

Hi Michiel

I had a similar question, and I've just updated that question with the code that appears to work. Link to that question below and the code. We had issues with the proxy and this seemed to sort it out, would be interested if anyone else had any comments or suggestions.

How to detect if a network proxy is being used?

Component.onCompleted{

if(AppFramework.network.proxy.type !== 2) { ArcGISRuntime.setupProxy(AppFramework.network.proxy.url) }

}

0 Kudos
Michielvan_Bemmel
New Contributor

Thx paul but im looking to make the proxy setting in the player permanent only for debugging purposes because my laptop is behind a corporate proxy. Our app is not using a proxy if it is running on a phone.

Now my current solution is in QT Creator is start player via tools>external>player

and i edited the arguments for starting the player under tools>external>configure and deleted the arguments under player so that the player opens in the normal and you can access the proxy settings.

Then set the proxy settings and don't close the player :) Now i can use my app with the proxy.

Annoying thing is every time the player closes you need to set the proxy again.

Maybe this also works for you.

0 Kudos