Quick Report Template Add New Feature Failed

03-01-2021 05:05 PM
New Contributor III


I used the Quick Report template to make an app that I can use to collect data in the field. Today I took it out into the field to test it. At one location, where I actually had cell service, I created an observation and saved it to my drafts folder since the cell service was spotty. When I got home this afternoon and connected to wi-fi I tried to submit the saved draft with two picture attachments. The first photo uploaded, then immediately afterwards I received an "Add new feature X Failed" message and the second photo is stuck on "Uploading...". Picture attached.

I am not sure if I set up the feature layer correctly in the settings window. Here is the link that I pasted in:


Maybe that is incorrect?

Also, the Feature Layer (hosted) on my ArcGIS Online content page is shared as Public and has a yellow circle with a pencil that says that it is approved for public data collection. When I check the Settings I have "Enable editing" selected and allow people to "Add". 

All screen shots included below, including the app spinning.  

Thanks for any help, I am sure that it is something easy that I have messed up.




0 Kudos
4 Replies
Esri Regular Contributor



This is weird, it looks correct. 

Has this ever worked before and then suddenly stopped working? Have you tried adding new report with an attachment? 


If you can submit a new report without an attachment, it might be related to this issue where there is no globalID in the feature layer. See this post on how to change the code, https://community.esri.com/t5/arcgis-appstudio-questions/quickreport-template-not-attaching-files/td... 


I hope this is helpful,


0 Kudos
New Contributor III

Hi Erwin

Thanks for the link, I actually saw it before I posted my question. I believe, if I am looking at my feature layer correctly, that I have a Global ID field (see attached screen shot). 

This has never worked before. This was my first field-test with the app. I am using AppStudio Player on my iPhone SE. I just tried to submit another new report with a photo and I get the same "Add new feature x Failed" message. 

Anything else you can think of?

Thanks so much


0 Kudos
New Contributor III

Hello Erwin

Any other suggestions?

I think at this point using Survey123 might be a better option for this project. It does not seem like AppStudio is ready for mass distribution for data collection. I have a Survey123 data collection survey that was created and deployed to over 1k users in less than two weeks. I have been working on this app for the better part of four months and am still spinning wheels.


0 Kudos
New Contributor

I don't know if you need help anymore, but seems like your point feature did not have the "allow editing" enabled.


0 Kudos