Offline Location Issues

267
2
03-01-2021 03:46 PM
GarrettRSmith
New Contributor III

Hello

I used the QuickReport template to develop an app for data collection in the field. The only things that I changed were text on pages and linking to my own content on ArcGIS Online through the "Settings" options.

Most, if not all, of my study area is located outside of cell phone range. When I was in the field today testing and had no service I never received any location (GPS) coordinate information on the map page. Alternatively, if I opened up a survey on Survey123, even though I had no service, I still had GPS readings on my geopoint question. There is no map in the Survey123 window because the study area and affiliated mmpk are not in the same location I am hoping to use the QuickReport app.

Is there something that I missed in trying to use this offline? 

I asked a question about loading an mmpk file but never received an answer on this forum. Does there need to be an mmpk map for the location to register?

Also, since I am taking photos in the field, I thought that even if I was offline that photos would create a point based on their embedded geotagged data. Am I wrong about this? When I got back home and looked at my drafts folder every location captured offline has no location based data. If I cannot collect locational data offline then using the app is no better than using Survey123 which works fine offline.

I am hopeful that this is simply my incompetence and not an inherent flaw in the app itself.

Thanks for any guidance.

0 Kudos
2 Replies
ErwinSoekianto
Esri Regular Contributor

@GarrettRSmith 

 

QuickReport support offline workflow by including the MMPK in the settings. Do you the MMPK included but it is not loading? or are you trying to use the app offline without MMPK?

 

Erwin

0 Kudos
GarrettRSmith
New Contributor III

Hi Erwin

I have a link to an ArcGIS Online mmpk file in the settings window of the app. Maybe I entered it wrong? 

The mmpk file does not download at all, when I am offline I just have a blank map and no location data displayed at the bottom of the map. When I take a picture and save a new report in my drafts folder, non of the offline reports have location data and I assume that means they will not upload correctly?

I have included screen shots of settings, mmpk file in my contents, and the mmpk file itself.

Again, like most issues I have had, this is probably something that I am not getting correct on my end.

Thanks

Garrett

0 Kudos