ArcGIS AppStudio Cloud Make Window Blank Screen

319
3
Jump to solution
03-03-2021 08:10 AM
KyleKaskie
New Contributor III

I have put together a custom application that I was looking at creating a window executable from. The application runs in both AppStudio and AppStuio Player. When I run through the steps and process of a "Make"; my final product, an executable, opens a blank or white page. 

I have been hitting dead ends when researching this issue but I must be missing something here. 

Thanks for any info related to my issue. 

Tags (4)
0 Kudos
1 Solution

Accepted Solutions
KyleKaskie
New Contributor III

It was traced down to a miss capitalization of a single letter in an import folder statement, deep within a control qml file. No errors were being thrown in apprun nor player, but this prevented the make from being created properly. 

View solution in original post

0 Kudos
3 Replies
ErwinSoekianto
Esri Regular Contributor

@KyleKaskie 

 

White screen normally is normally a sign in the QML. Did you make sure to test your app in the latest version of AppStudio Desktop AppRun or AppStudio Player, it is currently version 4.4. Because there is a chance that you are testing your code in the older version of Appstudio Desktop AppRun and AppStudio Player but when you do Cloud Make, it is always hitting the latest production version of 4.4. 

 

Can you test your app in the latest version of AppStudio Player to make sure there is no error message?

 

Erwin. 

KyleKaskie
New Contributor III

@ErwinSoekianto 

Thanks for the reply.

I am using the latest versions of AppStudio and AppStudio Player and run the application without issue. However, some of the components are copied over from prior applications built in previous versions. I will have to run though those individually and see if there are any updates to be made.

The things to note in my output would be these messages:

  1. QSqlDatabasePrivate::removeDatabase: connection '{cd7f5931-cf04-4d93-8c9b-0261540dba63}' is still in use, all queries will cease to work.

- which is thrown when I pop a window.

      2. Model size of -43 is less than 0

     Model size of -3 is less than 0

     Model size of -1 is less than 0

-which is thrown when viewing table viewes.

 

When I run debugger:

  1. bool __cdecl AppFramework::isOnline(void) *** DEPRECATED. Use Networking.isOnline instead. ** 

which is thrown even though my code is using Network.isOnline?

 

 

 

0 Kudos
KyleKaskie
New Contributor III

It was traced down to a miss capitalization of a single letter in an import folder statement, deep within a control qml file. No errors were being thrown in apprun nor player, but this prevented the make from being created properly. 

View solution in original post

0 Kudos