How to change the basic category types in the selection of Report Type ( and fields for comments that the users may add) in Quick Report Template App?

441
4
11-11-2017 11:54 AM
NadezhdaGerasimova
New Contributor

How to change the basic category types in the selection of Report Type  ( and fields for comments that the users may add) in Quick Report Template App? Is it possible to do on-line in App Studio with a basic license or only with a Pro one? Or is it possible only in Desktop App Studio?

Tags (1)
0 Kudos
4 Replies
nakulmanocha
Esri Regular Contributor

Basic category types and the fields come from the feature service layer. Category types are defined by the Type ID field in you feature service layer which is essentially the editable subtypes in the feature layer. This is configured in ArcGIS Pro or ArcMap before being pushed to ArcGIS Server or Online. This is not dependent on AppStudio Standard or Basic License.Hence once it is configured with subtypes and published with service you can configure the service in your Quick report template app irrespective of the app created on AppStudio wesbite or using the standard license. To learn more about feature service subtypes and type id check the following link

Layer - Feature Service 

Nakul

0 Kudos
JaguarDigital
New Contributor III

Hi

 

I'm using Quick Report template on Appstudio, the reports were working ok, but after I added subtypes to the Feature Layer through ArcGIS Pro desktop, the reports are now generating an error at the upload page, and the data never arrives to the server, as seen on the right image (the error message in spanish in the next image says "Add new feature - Error"). This error appears equally on the desktop and in the Appstudio Player on iPhone. I tried without adding an attachment, but it doesn't work either. 

At some point of the development I compiled the Data Collection app (Data Collection | ArcGIS for Developers) in Xcode and when I run it on an iPhone it can connect to exactly the same Feature Layer URL and upload the reports without error (even including a photo attachment). That's why I doubt there is any configuration error of the Feature Layer. The next image shows the report being saved on Data Collection:

 

 

When I try to debug the Appstudio project in QT Creator, it shows these lines on the Debugger Console (I suppose the 405 error is the origin of the issue, but I can't be sure): 

 

 

I haven't found any other clue to solve the error, and given the fact that it works fine in the Data Collection app, I'm currently puzzled why this is happening. Any help will be appreciated

 

Oscar

JaguarDigital
New Contributor III

Ok, I found the error. It was because the Feature Layer didn't have a GlobalID field created before adding the attachments tables. On ArcGIS Pro I deleted the attachments tables, created the GlobalID field on the Feature Layer and regenerated the attachments.

Curiously enough, neither the Data Collection App nor the Crowdsource Reporter Web App had any issue submitting the reports, but the Quick Report did have it.

Maybe this answer will help someone, I found a similar one here: Enable Apply Edits With Global Ids on ArcGIS Feature Services 

0 Kudos
ErwinSoekianto
Esri Regular Contributor

Jaguar, 

Yes, if you are using Quick Report template version 4.2, this may have something to do with GlobalID, or rather lack thereof. 

If you think you can not add GlobalID to your feature layer, you can make this change to the code in QuickReport/QuickReportApp.qml around line 1211 inside the function submitReport() to remove the first 3 lines to try to submit report with GlobalID, as shown in the screenshot below. 

I hope this is helpful,

Erwin