Unable to find ItemInfo for item

547
2
05-21-2019 05:11 AM
NikolajGrønholdt
Esri Contributor

I am experiencing a problem, when trying to use content.get(some item.id), in a script that indexes all the content of a Portal 10.7. When I run the script, It returns an error stating: 

RuntimeError: Unable to find ItemInfo for item 'some id' (Error Code: 500)

It don't quite understand it, given that I have retrieved the id through content.search. So the item should be available on my portal. 

Anybody who can point me in the direction for figuring this out?

0 Kudos
2 Replies
MarisaClaggett
Occasional Contributor II

Hi,

Do you have a snippet of the python you are using?  Can you manually look up that item id in your Portal?  What is the item type?

Best of luck,

Marisa

0 Kudos
NikolajGrønholdt
Esri Contributor

Hi Marisa, 

I experienced the error first in a quite complex loop, so I thought that it was a syntax problem. However, the error occurs even when using a simple gis.content.get("id"). The id that my script returns is 9b39c07049f64494ad8514d88aeadbc2, if it is of any interest. 

I have since tried searching for it in the Portal as well, and it returns an item created by Esri (Screenshot below). When I try to access it by clicking view item details, my browser gets stuck loading the item details page. 

0 Kudos