Model Training Error: Deep Learning in ArcGIS Online Notebooks

10-04-2022 04:38 PM
New Contributor

Hi ESRI Community,

I'd like to use the MultiTaskRoadExtractor module in arcgis.learn to extract ATV tracks from aerial imagery. My intended deep learning analysis will be very similar to the Streams Extraction using Multi-Task Road Extractor exercise so I am trying to successfully run this example analysis in an ArcGIS Online Notebook first before modifying the code to suit my specific needs. 

Oddly, when I run the example in an "Advanced" notebook, I receive no errors, though it takes over 1.5 hours to run each model fitting epoch. When I run the same example analysis in an "Advanced with GPU Support" Notebook, I receive the following error when attempting to fit the model:


I have tried this in versions 1.9.1 and 2.0.1 of arcgis API with the same error. Any suggestions? 

Thanks in advance for any help resolving this issue!

0 Kudos
1 Reply
Esri Contributor

Hi TristanAmaral1,

Thanks for this post. In my testing, I see this model run successfully in both ‘Advanced’ and ‘Advanced with GPU support’ runtimes with recent ArcGIS Online 10.3 update Can you retest your scenario, and confirm if this is still an issue?

If the issue persists, try declaring the environmental variable as “%env BLOCK_MODEL_TRAINING=0“ before training the model using fit() method. Hope this helps!

Best Regards,


0 Kudos