Insufficient permissions error on API key that has the correct permissions

11-09-2022 09:58 AM
Labels (1)
New Contributor

I have a geoenrichment script that I've used extensively in the past, and it's always worked. Two days ago I came back to use it (after having not used it for a few weeks) and have been getting the following error:

AssertionError: Cannot enrich due to insufficient permissions. Please ensure the GIS object instance is created with credentials, a user, with permissions to perform geoenrichment.

I am using an API key on a developer account to authenticate, and it's always worked in the past. I have double checked that GeoEnrichment is turned on for this API key, and I've even setup new API keys with all services turned on to test and got the same results.

I'm at a loss on why this would be happening. I've included a sample script below that demonstrates the issue with a sample enrichment from Esri's documentation... I can't even get this simple script to work with any API Key. I only have a pay-as-you-go developer account, so I cannot use a username and password (plus for my needs, an API key is preferred).

Anyone have any ideas?

Sample Code:


import pandas as pd
from arcgis.gis import GIS
from arcgis.geoenrichment import *

gis = GIS(api_key="API_KEY_GOES_HERE")

single_address = enrich(study_areas=["380 New York St Redlands CA 92373"], 




0 Kudos
1 Reply
New Contributor



I am facing the exact same issue. I made sure that my API app has GeoEnrichment listed as an authorized service, but I get the same error as you. Were you able to figure out a solution for this problem?


Thanks in advance!


0 Kudos