ImportError: No module named 'arcgis'

6925
5
06-02-2017 08:50 AM
Highlighted
by
New Contributor II

I was able to import the arcgis module in jupyter notebook fine until today.

The interpreter is unable to find the arcgis module even though 'arcgis-1.0-py35_1' exists in 'C:\Program Files\Miniconda3\pkgs'. 

When I run the cell with 'from arcgis.gis import GIS', I Keep getting this error - ImportError: No module named 'arcgis' 

The arcgis package files are all intact. 

Any incompatibility issues I need to check?

Tags (3)
5 Replies
Highlighted
Esri Contributor

Did you make any changes to your computer such as installing another Python interpreter? Such actions could change your default Python and point your sys path environment to something else. To ensure your notebooks run off the desired interpreter (in this case the miniconda env in which you installed the Python API), always activate that environment before you start the notebook.

If you doubt your conda environment may not have the ArcGIS library, you can do a 

conda list

to see the list of all packages and ensure 'arcgis' is listed with its version number.

Highlighted
Occasional Contributor II

I tried the conda list and did not see arcgis but did see arcgispro. Does this mean I should import from arcgispro or is there something else I need to do to ensure the arcgis library is loaded?

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

install ArcGIS from the package manager within ArcGIS pro... that is the simplest.. then if you have to do the conda line, you will see it when you do conda list

Highlighted
New Contributor III

how do I activate an alternative python environment?

Reply
0 Kudos
Highlighted
New Contributor II

conda install -c esri arcgis

worked for me in the conda environment.