I,m trying to implement building footprint detection using Deep Learning as shown in this example Extracting Building Footprints From Drone Data | ArcGIS for Developers with my own data. But I'm getting the following error when I run the prepare_data() function.
The command I ran was
The packages that I'm using in my environment is shown below. This environment was created by cloning the default arcgis environment (ArcGIS Pro 2.4.3) from the Python package manager and then manually installing the packages (using pip) that were missing when compared to an environment that was created using the command 'conda install -c esri arcgis deep-learning-essentials --no-pin'. Please note that the missing packages that were installed were the latest versions and not the same versions as that of the environment created using the above command.
Any suggestions, comments or solutions are welcome.
You can use this command to add missing packages and correct versions of a few
Same issue for me too. Why doesn't ArcGIS recognizes the most recent deep learning framework versions? Are the versions which you mentioned above, the minimum versions required or the exact versions required?. I am assuming if I have PyTorch 1.3.0, it should still run without throwing any errors, but it still throwing up an error for me.
Have you made any progress on this? I am currently running into the same problem with each package installed in the active cloned environment but still being asked to install them.
I am pasting the current installation commands From the documentation page here.
conda install -c esri -c fastai -c pytorch arcgis=1.8.2 scikit-image=0.15.0 pillow=6.2.2 libtiff=4.0.10 fastai=1.0.60 pytorch=1.4.0 torchvision=0.5.0 --no-pin
Let me know the issues which you are facing.
Thank you Sandeep.
I had trouble with cloning the environment within ArcGISPro but doing everything via the python command prompt and using the versions for the various packages you provided, it worked out fine.