Can't update the arcgispro package

1553
3
02-07-2019 04:27 PM
simoxu
by MVP Regular Contributor
MVP Regular Contributor

After upgrading my ArcGIS Pro to 2.3, the python environment I previously cloned and then modified stopped working because of the "version mismatch":

 

When I list the arcgis related packages I find the arcgispro package version is still 2.2, but the latest version should the be 2.3, and I believe that's why ArcGIS Pro reported "verion mismatch".

So I tried to install arcgispro 2.3 in my environment, but this seems not allowed, because there were conflicts.Please see below:

Since I have installed many other third-party packages, I don't want to give up my current environment until I run out of options. 

I have cloned the default env of the new ArcGIS Pro 2.3, and successfully upgraded the ArcGIS Python API to 1.5.3, this re-assures that ArcGIS Python API 1.5.3 is compatible, it's the arcgispro 2.2 python package which is causing the problem.

Anyone has the same issue?

0 Kudos
3 Replies
DanPatterson_Retired
MVP Esteemed Contributor

do you actually have ArcGIS Pro 2.2 and 2.3 installed?

2.3 comes with 1.5.2...

I just did a "dry-run" on updating ArcGIS 1.5.2 to 1.5.3 and this is the package plan.

I don't use the clone though, I just make updates to the  "envs\arcgispro" environment.

(arcgispro-py3) C:\arc_pro\bin\Python\envs\arcgispro-py3>conda update arcgis --dry-run
Fetching package metadata .............
Solving package specifications: .

Package plan for installation in environment C:\arc_pro\bin\Python\envs\arcgispro-py3:

The following packages will be UPDATED:

    arcgis:          1.5.2-py36hd5a64b8_2  esri --> 1.5.3-py36h66efe7d_1  esri
    ca-certificates: 2018.12.5-0                --> 2019.1.23-0
    decorator:       4.3.0-py36_0               --> 4.3.2-py36_0
    openpyxl:        2.5.12-py36_0              --> 2.5.14-py_0
    pandas:          0.24.0-py36ha925a31_0      --> 0.24.1-py36ha925a31_0
    parso:           0.3.1-py36_0               --> 0.3.2-py36_0
    pip:             18.1-py36_0                --> 19.0.1-py36_0
    prompt_toolkit:  2.0.7-py36_0               --> 2.0.8-py_0
    pyopenssl:       18.0.0-py36_0              --> 19.0.0-py36_0
    pytest:          4.1.1-py36_0               --> 4.2.0-py36_0
    pyzmq:           17.1.2-py36hfa6e2cd_0      --> 17.1.2-py36ha925a31_2
    setuptools:      40.6.3-py36_0              --> 40.7.3-py36_0
    zeromq:          4.2.5-he025d50_1           --> 4.3.1-h33f27b4_3‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍‍
simoxu
by MVP Regular Contributor
MVP Regular Contributor

Thank you Dan.

I upgraded to ArcGIS Pro 2.3.0.

and surprisingly, the ArcGIS Python API in my Pro 2.3 is 1.5.1 not 1.5.2.

The reason I cloned the environment to upgrade is the default environment doesn't allow modification. Please see the snipped screenshot below

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

The default environment is 'pinned' and can't be updated.

You can either clone, and change your working environment into the clone... or.

do what I do, use conda to update the default, but I am administrator on my computer.

So if you aren't the master of your environment, mess with the clone, or

I think the clone is to stop people calling when they foul up the default environment. By having a clone, the original is still there.

I can't have the extra baggage kicking around, and I haven't installed anything that has brought the house down.

Worst case scenario... uninstall all vestiges of Arc* and rerun the *.msi from the download to reinstall