Firefox version requirement for vector basemaps

987
2
Jump to solution
08-16-2016 08:02 AM
MarcBate
Occasional Contributor

Vector basemaps were not working on a coworker's old version of Firefox, but worked after updating his browser. I'd like my app to check the Firefox version and give them a warning or replace the selected vector basemap with the raster equivalent. What specific version do I need to look for?

0 Kudos
1 Solution

Accepted Solutions
ReneRubalcava
Frequent Contributor

Vector basemaps require WebGL support.

You can check for browser support here.

http://caniuse.com/#feat=webgl 

Here is an MDN article on how to check for support.

Detect WebGL - Learning web development | MDN 

View solution in original post

2 Replies
ReneRubalcava
Frequent Contributor

Vector basemaps require WebGL support.

You can check for browser support here.

http://caniuse.com/#feat=webgl 

Here is an MDN article on how to check for support.

Detect WebGL - Learning web development | MDN 

View solution in original post

MarcBate
Occasional Contributor

It may be nice for the API to revert to the non-vector version of the basemap if the browser doesn't support WebGL

0 Kudos