What is the lates version of ArcGIS Server that can be use with the JavaScript API?

287
1
02-14-2013 04:30 AM
HectorMelendez-Alvarado
New Contributor III
I'm about to start a new proyect for a client that has ArcGIS Server 9.3.1 and was wondering if the latest version of the ArcGIS API for JavaScript works with that version of ArcGIS Server. Are there any significant limitations of using the latest JavaScript API with 9.3.1 Services?
0 Kudos
1 Reply
AnthonyGiles
Frequent Contributor II
Hector,

The JS API is backward compatible so you should be able to use the latet 3.3 with a 9.3.1 server.  The only caveat is that you cannot use JS API features that aren't supported by the release of ArcGIS Server you're using. For instance, you would not be able to do any editing against your services or time aware layers etc. If you're just displaying and querying, you should be good to go.

Regards

Anthony
0 Kudos