Popup in FeatureLayer does not work with Internet Explorer 11

856
4
02-07-2017 10:54 AM
ManuelGranados
New Contributor II

I am creating a FeatureLayer with client side graphics and attaching a popup to the layer, but the popup does not display when using Internet Explorer 11; with Chrome there is no problem. I checked the sample code in the ESRI web site (https://developers.arcgis.com/javascript/latest/sample-code/sandbox/index.html?sample=layers-feature...) and the problem persists. However, if I change the version in the sandbox of the sample code to 4.1, it works in IE 11 (the popup is displayed). Is this a problem with version 4.2 and IE11? Is there a quick solution?

Thanks!

4 Replies
MikeDolbow
New Contributor III

Did you ever figure this out? I am working with 4.14 and the first time after a search the popup appears with no content. The second time through it works as expected.

0 Kudos
StefanUseldinger
Occasional Contributor

Doesn't work for me either in 4.15 using Internet Explorer 11.

I receive the message:

SCRIPT438: Object doesn't support property or method 'forEach'

Feature.js (103,41)

The Popup does not load properly.

Test page: here (Esri NL data, hosted on ArcGIS Online)  or here (my data, hosted on my Portal)

The problem always shows up, if I set Display = A description from one field

0 Kudos
StefanUseldinger
Occasional Contributor

Here's an example using a sandbox: https://jsfiddle.net/z6jLr2op/2/embedded/result,html

The problem occurs when using:

content: [{

    type: "text",

    text: "{naam}"

}]

Instead, the following code works:

content: "{naam}"

According to the doc, both PopupTemplates should work.

0 Kudos
StefanUseldinger
Occasional Contributor

This is now a BUG-000130719

0 Kudos