Microsoft Edge will not load a TileLayer

07-11-2019 09:05 PM
Occasional Contributor II

My map will not load and I get this in the console when using Edge.

[esri.layers.TileLayer] #load() Failed to load layer (title: 'Aerial', id: '16be45292c8-layer-0') [request:server]: Unable to load status: 0

I was getting this while using ArcGis JS 3x and so I converted the map to 4x but I still get this error and the map won't load.

0 Kudos
2 Replies
Esri Regular Contributor

Hi Andrew, sorry to hear about this issue. I tested a handful of 4x and 3x tile layer samples using Edge, and I did not see any errors. Here are my Edge and OS versions:

Windows 10
Microsoft Edge 42.17134.1.0
Microsoft EdgeHTML 17.17134

Could you try updating your version of Edge, or post a link to a hosted sample so I could test the same one you are seeing the error with?


0 Kudos
Occasional Contributor II

Hi Noah,

I'm using Microsoft Edge 44.17763.1.0, Microsoft EdgeHTML 18.17763. This problem only occurs when the Tilelayer is loaded into a webmap that is not hosted on our web adaptor server. We are currently migrating from ArcGIS 10.3.1 to Enterprise 10.6.1 and I tested this in our new environment with a Tilelayer hosted there and it worked, no problems at all. Please don't do any more investigation of this problem, unless you are personally interested, as it appears that it will be resolved once all our services are hosted on 10.6.1.