JS API: polyline and polygon post in 2D, but polygon not in 3D

483
1
Jump to solution
04-09-2021 10:11 PM
devzolnai
New Contributor II

Created polyline and polygon in Desktop Pro, to post on Mars 2000 (Globe) Web Scene via JS API.

CodePen1 shows that polyline grid and polygon surface post as a Web Map.

CodePen2 shows the polyline posting in Web Scene but not the polygon.

Both show parallel and bare minimum code to avoid unrelated gremlins.

What am I missing? Thanks, Andrew

 

1 Solution

Accepted Solutions
devzolnai
New Contributor II

@ArnoFiva : "So your areoidLevel feature layer seems to contain a single polygon only, I'm assuming positioned at sea level. Because the z-values are accounted for by the Scene View, it draws the polygon going straight through the globe. You can see it inside the globe by setting the ground opacity. [1]
If you want to see the polygon draped onto the SceneView globe which essentially represents sea level (aka areoid, learned something there thank you!), you have to set the elevation mode on the FL [2] ..."

Resolved in CodePen2 l.37-39 [2] and l. 68 [1]


[ aeroid level is Martian for sea level HT @kennethfield ]

View solution in original post

0 Kudos
1 Reply
devzolnai
New Contributor II

@ArnoFiva : "So your areoidLevel feature layer seems to contain a single polygon only, I'm assuming positioned at sea level. Because the z-values are accounted for by the Scene View, it draws the polygon going straight through the globe. You can see it inside the globe by setting the ground opacity. [1]
If you want to see the polygon draped onto the SceneView globe which essentially represents sea level (aka areoid, learned something there thank you!), you have to set the elevation mode on the FL [2] ..."

Resolved in CodePen2 l.37-39 [2] and l. 68 [1]


[ aeroid level is Martian for sea level HT @kennethfield ]

0 Kudos