JS API 4.10 Error Custom build (Dojo) Node.js

539
2
04-04-2019 03:14 AM
FabianMolina
New Contributor

I'm trying to make a custom build using the 4.10 JS API, but I keep getting a build error:

18 verbose node v10.15.1 19 verbose npm  v6.9.0 20 error code ELIFECYCLE 21 error errno 3 22 error arcgis-js-api-sample-app@1.0.0 build: `grunt build` 22 error Exit status 3 23 error Failed at the arcgis-js-api-sample-app@1.0.0 build script. 23 error This is probably not a problem with npm. There is likely additional logging output above.

Before in the 'npm install'  I had this error:

verbose stack Error: node-sass@4.7.2 postinstall: `node scripts/build.js`

So, I changed the "node-sass" version by  "node-sass": "~4.9.0" in the package.json file.

I'm using the one recommended in the 4.x JS API Bower section guide from here: Using npm for Custom Builds

0 Kudos
2 Replies
ReneRubalcava
Frequent Contributor II

Can you try this sample here. I'll be updating this for 4.11 today or tomorrow, but right now it is still 4.10 and should work as expected.

PeterWiringa
New Contributor III

I think I'm running into the same problem under OS X with a newer version of node-sass, with a similar fix (fails: ~4.11.0, succeeds: ~4.12.0). Seeing this with both the @arcgis/cli and the npm demo for 4.x in the latest jsapi-resources. Opened an issue on the arcgis-cli side. https://github.com/Esri/arcgis-js-cli/issues/33

0 Kudos