Error 404 when try to configure webadaptor for portal for arcgis

07-12-2017 06:28 AM
New Contributor

After installing ArcGIS Server and Arcgis Portal, I am trying to configure the web adaptor to use it with portal but when I navigate this url: https://localhost/arcgis/webadaptor/portal , I have error 404 or a white page without any message.

Arcgis Server is 10.5

Arcgis Portal is 10.5

Arcgis Web adaptor is 10.5

OS is Windows 10

I am using web adaptor with IIS.

How can I solve this? Is there a bug with the web adaptor?? 

Please help me!!

0 Kudos
12 Replies
MVP Esteemed Contributor

You should use the FQDN (Fully Qualified Domain Name) instead of "localhost".

Also ensure that webadaptor instance name is correct.

And this note (Did you install ArcGIS Web Adaptor on Port 80?).

Before proceeding, ensure ArcGIS Web Adaptor is installed on a website running on port 80. ArcGIS Web Adaptor cannot be configured with Portal for ArcGIS if it's installed on a website running on a port other than 80.

Configure ArcGIS Web Adaptor—Installation Guides (10.5) | ArcGIS Enterprise 

Think Location
New Contributor

I have installed the web adaptor on port 80 and I have tried to access to the web adaptor via FQDN but the result is the same.

If I use the FQDN, I can access to the home page of web adaptor (via http)

but if I select Portal for Arcgis and go next, I have a blank page.

If I try to access via https I have error 404.

Suggestion? How can I solve it?


0 Kudos
New Contributor II

I think you have to install the SSL certificate on the server and bind it to port 443 before you can run it in 10.5. I think at 10.5 Portal you can only go through 443 and not 80.

New Contributor III

hi susmita duncan.

I do have exactly the same problem.  I did install SSL certification on the server.  I am not exactly sure of "bind it to port 443 before you can run it in 10.5." and "10.5 Portal you can only go through 443 and not 80."  

can you tell me more detail about it?


0 Kudos
New Contributor III


I am at the same boat now.  I can access everything beside portal with webadaptor.  have you find any solution for that?


0 Kudos
MVP Esteemed Contributor

Portal requires one (and only one) web adaptor, and it cannot be the same name as one used for ArcGIS Server.

Some topics that might help.

Portal for ArcGIS 10.5.x system requirements—Installation Guides (10.5) | ArcGIS Enterprise 

About the ArcGIS Web Adaptor—Installation Guides (10.5) | ArcGIS Enterprise 

Install ArcGIS Web Adaptor—Installation Guides (10.5) | ArcGIS Enterprise 

and info on troubleshooting the install Installing Portal for ArcGIS—Installation Guides (10.5) | ArcGIS Enterprise  (bottom of that page, if it doesn't go directly to it)

Esri Regular Contributor


According to the screenshot above, the 404 message appears to be coming from some web server other than IIS or Tomcat. That looks like a message from Apache. Do you have a reverse proxy in place?

0 Kudos
New Contributor III

I have the same error code but iis is used. Here are the details.

I have a simple question about web adaptor setting for my new arcgis portal.

In a machine(AWS), I installed Arcgis Server 10.5, Portal 10.5, GeoEvent server 10.5, web adaptor 10.5 (arcgis/portal)

I can access the server (server manager with web adaptor, geoevent without web adaptor) from a different network.  Unfortunately, not the portal site.


Question is as follows.

  1. I was able to setup web adaptor for ArcGIS server then, I can access to the manager site https://xxxxx/arcgis/manager from a different network. I could not configure web adaptor(arcgis) for Portal.  When I select the PORTAL, server returns HTTP 400 error. 
    Thus I created an additional web adaptor (portal), however, I am getting the same error.  
    And, I can access to portal site with port number from the server.  However cannot access to the port site from a different network.  It will redirect the “address from” to “”


If you have any suggestions please guide me to the right direction.

0 Kudos
New Contributor

I just ran into this same issue and after working through re-installing web adaptor several times, checking file permissions, changing certificates, the solution ended up being something simple.  I called Tech Support and was able to get it resolved quickly.  When creating the binding on my certificate, I had entered the Host Name.  For some reason this was causing the web adaptor to not be able to configure the Portal while Server was still fine.  Whenever this was left blank I was able to configure web adaptor right away.

Hope this helps with future configurations.