ArcGIS Server blocks the request to services

04-18-2018 04:13 AM
New Contributor

Hi everyone, 

I have developed GIS application using the CMV template and I have a created simple html page to validate some data using Feature Tables, which are linked. 

Once I select data to review in the CMV application,  I open new window with map and Feature table on it, the request to the feature service is blocked by the ArcGIS Server and none of the services are loading to the map. 

I've logged into the ArcGIS Server Manager where I got this error :  "Result limit: 10 reached; ignoring any remaining objects in the query result for Layer: LayerName1" 
and similar error for another service "Result limit: 50 reached; ignoring any remaining objects in the query result for Layer:LayerName2"

In the browser, in the Network tab, I check the request but I got the following error : "Could not access any server machines. Please contact your system administrator. "

So, any ideas how to solve this problem or maybe some workaround approach to fixed it?


10 Replies
Occasional Contributor II

Did you ever figure out what was causing this?

0 Kudos
New Contributor III

I'm having the exact same warning show up. Has anyone figured out what is going on with it?

0 Kudos
Occasional Contributor II

I have this persistent WARNING, too. Mine is limiting the query results to 6. This WARNING is always accompanied by a separate SEVERE message stating "General geodatabase error occured." (sic). 

My feature service has two layers and a table, which are all from the same database and are all related using relationship classes in the geodatabase.

To be clear, the rest service URLs for each layer all show that the max record count is set to 1000.

ESRI has attempted to help me troubleshoot this, but could not find a recommendation other than to upgrade our server. We did this: from SQL Server 2012 to 2016, plus ESRI professional services deployed a new, separate web server for us that has been upgraded to Enterprise 10.6.1. Both have had their memory and RAM increased. We are now using Portal instead of ArcGIS Online.

And yet, this issue persists on our most important feature service.

0 Kudos
New Contributor III


we are also having several issues working with Feature Services through Collector for ArcGIS (Online and Offline editing) on ArcGIS enterprise 10.6.1. We get same kind of errors "Result Limit..." and 2 or 3 times per day ArcGIS Enterprse hangs, it's not possible to access Manager or Portal Home. Restarting ArcGIS Server windows service, everything start working.

No solution or workaround yet.

Thank you

0 Kudos
New Contributor III

Hi, I´m trying to use the Chart widget in WAB, in the preview of the configuration it does show the graphics, however when lunched the widget does not show the graphic. While reviewing the server manager logs I found WARNING "Result limit: 50 reached; ignoring any remaining objects in the query result for layer" and  SEVERE "An error ocurred". The maxrecordcount for the services I tested are 1000 or higher. 

Has anyone figured out where does that result limit come from and how to increase it? 

The platform I´m testing is Enterprise 10.6.1 recently upgraded from 10.5, and the issue with the Chart started after the upgrade. And I have another platform with Enterprise 10.6.1 working perfectly, I just have not found where to configure the result limit. 

0 Kudos
New Contributor III

Just to update the information. I opened a support case with Esri Inc and the response was that the chart widget is obsolete. The end user moved from chart widget to infographic widget.

0 Kudos
Occasional Contributor II

Hi All

Has anyone found a resolution to this?  We have Enterprise Portal 10.6.1 and am trying to join a csv from a web service to a hosted feature layer and we are seeing a similar error.

Result limit: 50 reached; ignoring any remaining objects in the query result for Layer

0 Kudos
New Contributor III

I noticed that a simple service of mine was not showing the domain descriptions, just the codes and looked at the ArcGIS Server Manager log where I got the same message as you guys

"Result limit: 50 reached; ignoring any remaining objects in the query result for Layer: Pollare."

I also see this message in the log:

"Method failed.HRESULT = 0x80070057 : The parameter is incorrect. ."

Sorry to see that no one has gotten a response on what this could me yet...

I really want to fix this since my surveyor is not able to choose a domain value in the service now. It just shows as a text field and allows you to write text in it instead of the drop down menu. I have increased the maxDomainCodeCount of the service, but it doesn't help.

0 Kudos
New Contributor II

I am getting the same error. Has this been elevated to a bug? Other than rebooting the windows services is there a fix for this?