ArcGIS Javascript - '_getInfo' of undefined

6319
6
05-31-2016 08:21 AM
AvinashRamamurthy
New Contributor

I am using "cesri loaded: Map API: [2.0.96], ESRI API: [3.16], included Dojo: [1.10.4 (f4fef70)]". I could not find the root cause of this issue "Cannot read property '_getInfo' of undefined". Could anyone please help me to come out of this.

Thanks in advance.

Tags (1)
0 Kudos
6 Replies
thejuskambi
Regular Contributor

Please add some code and/or more details about the functionality you are trying to achieve, to get some response. Providing us the error message is not useful, for us to help you.

Thanks you.

0 Kudos
AmmarAmeerdeen
New Contributor

Following is the problematic code.

require([
"esri/map",
"esri/toolbars/edit",
"esri/graphic",

"esri/symbols/SimpleMarkerSymbol",
"esri/symbols/SimpleLineSymbol",
"esri/symbols/SimpleFillSymbol",
"esri/layers/GraphicsLayer",

"dojo/parser",
"dijit/registry",

"dijit/layout/BorderContainer",
"dijit/layout/ContentPane",
"dijit/form/Button",
"dijit/WidgetSet",
"dojo/domReady!"

], function(
Map, Edit, Graphic,
SimpleMarkerSymbol, SimpleLineSymbol, SimpleFillSymbol, GraphicsLayer,
parser, registry
){}

0 Kudos
KubaSzostak1
New Contributor III

I have the same issue. It happens irregular, so it's hard to debug. My console output:

Uncaught TypeError: Cannot read property '_getInfo' of undefined
at Map._getFrameWidth (init.js:578)
at Map._setClipRect (init.js:617)
at Map.onResize (init.js:598)
at Object.advice (init.js:119)
at Map.c [as onResize] (init.js:119)
at Map._resize (init.js:616)
at Map._execResize (init.js:614)
at Map._execResize (init.js:63)
at Map._timedResize (init.js:614)
at init.js:63

https://js.arcgis.com/3.23/init.js 

MajuSadagopan
New Contributor II

Did anyone find a solution to this? We're receiving the same error on a client's computer on chrome.

0 Kudos
SewonKim
New Contributor

In 2020, with ArcGIS Enterprise 10.8.1, we are experiencing exactly same error.

For some reason, same Creator account opens Web AppBuilder app on some machines fine and gets this error on another.

Any help would be appreciated.

0 Kudos
LoriMcCormack1
New Contributor II

I had the same message as shown above on 02-26-2018, and found the issue for me.  The map service was referencing a REST URL that no longer existed.  Once I changed the REST URL to a valid one, the error went away and my ArcGIS API for JavaScript version 3.2x worked.

0 Kudos