Business Analyst - Drive Time API

04-27-2011 08:14 AM
New Contributor
Hello.  I am trying to get muliple reports to come up when a user clicks a point on the map.  I used to have this working - however, I hadn't done anything with this for a few months and when I went back to run the drivetime.mxml it now comes up with an error when trying to get the reports.  If I take out the code that adds the second report - then the one report with come up w/o errors.

This is the code I have currently:

// report options - 1st Report (Add "1" to option & header)
var option1:ReportOptions = new ReportOptions();
option1.templateName = "dandi";
option1.format = "PDF";
// customize report headers
var header1:ReportHeader = new ReportHeader("5-10-15 Min Drive Time Study Areas");
header1.address1 = "City of Liberty, Missouri";
header1.address2 = "";
// custom logo in report
header1.customLogo = ""
option1.header = header1;
//report options - 2nd report (Add "2" to option & header)
var option2:ReportOptions = new ReportOptions();
option2.templateName = "dispinc";
option2.format = "PDF";
var header2:ReportHeader = new ReportHeader("5-10-15 Min Drive Time Study Areas");
header2.address1 = "City of Liberty, Missouri";
header2.address2 = "";
// custom logo in report
header2.customLogo = ""
option2.header = header2;
params.reportOptions = [option1, option2];
var driveTimeTask : DriveTimeTask  = new DriveTimeTask(baClient);
driveTimeTask.execute(params, new mx.rpc.Responder(resultHandler, faultHandler));

Like I said - it worked using this code initially - but for whatever reason it won't do so now.

Any ideas?

Tags (2)
0 Kudos
3 Replies
New Contributor
Looks like the issue might be with the URL of the custom logo. When I try to view in a browser, I get a 'Server Login' error. If I change the logo to some other image, the request works.

0 Kudos
New Contributor
You are a genius!  Thanks!  It had been a while since I had been working on the BAO API and I couldn't for the life of me figure out what I had done to it to make it no longer work as it had worked initially!

So then the question comes down to - what do I need to do in order to get a custom logo?  I am obviously not doing something right.

Any ideas?

0 Kudos
New Contributor II
Did you get the customlogo to work?  Not happening for me.

0 Kudos