JavaScript API Interoperability with Other Loaders

Idea created by sgourley on Mar 13, 2017
    New
    Score240

    The 3.x and 4.x javascript api's and their use of dojo loader plugins lock developers into using the dojo loader and the legacy dojo build system - or it places the burden on the developer to create custom module loader implementations. I would like to see esri support the interoperability of module loading moving forward so developers can use modern loading/build/bundling tools with the 4.x api's without a lot of friction. 

     

    If this idea is accepted, developers cannot complain about the implementation details of the javascript api leaking into their workflows/technology decisions. The esri technology decisions of the api will be an implementation detail instead of an influence.