AnsweredAssumed Answered

ArcGIS Server 10.1 - Web Adaptor Installs files to wrong location using Silent Instal

Question asked by harley on Aug 20, 2012
Latest reply on Oct 17, 2012 by harley
After failing the standard install process, I tried the slient install described in the help document here:
And to be clear, using the uninstall from the same help documents.

When I did, the installation created the web folders needed in the wrong place. I tried moving the folders, but that didn't resolve the issue, and right now working on changing rights, permissions,etc.

what we need is a set of instructions which resolves something like the Knowledge articles on arcgis server 9.3.1

the existing knowledgebase article here is lacking the discussion about setting up a user account or Group with rights to edit the webadaptor.config file: Error:  Application Error: Access to the path ???C:\Inetpub\wwwroot\arcgis\WebAdaptor.config??? is denied .

also this kbase which tells us to use 2.0 .NET:  Error:  HTTP Error 500.19 - Internal Server Error "The requested page cannot be accessed because the related configuration data for the page is invalid"

Also, for continuity, this is a good forum thread on similar issues:

there is then this Error:  Failed to create the site. Failed to create the service 'System/CachingTools.GPServer':

Which reminds me, need to make sure that the services includes the ports being communicated on to the GIS Servers on port 6080.
agsoc             6080/tcp #arcgis server ports for gis data and managment communication
agsoc             6080/udp #arcgis server ports for gis data and managment communication

It should be noted that 10.1 is really new to me, and this installation includes a arcgis spatial data server and seperate web site with the web adaptor.
If you have not seen the admin page it looks like this on the hosting spatial data server:

If anyone has similar installation problems with the Web Adaptor for 10.1, your feedback is requested.

Note: this deployment scenario  is a web server w/ adaptor, single geospatial server, and data store.
at this point, just trying to get the adaptor to see the geospatial server.