alberto69

Problems with java add-ins

Discussion created by alberto69 on May 23, 2012
Latest reply on May 31, 2012 by alberto69
Hello everyone.

Since ArcGIS 10 supports java for desktop development too, I tried to set up a java add-in for ArcMap. Before writing my own add-in I had a go with one of the samples provided by the Java SDK, called "simpleaddin".

I can add the add-in to ArcMap without problems, and I can see it listed in the Add-In Manager.

Unfortunately, when I bring up the add-in toolbar (SampleJava Toolbar) in ArcMap, no custom commands are shown, just a bunch of labels saying "missing". Native ArcMap commands (like Fixed Zoom Out) are visible on the toolbar though (see attached image).

I also tried to create my own add-in, following the instructions given in this video:

http://resources.arcgis.com/gallery/video/java/details?entryID=F8A0A38E-1422-2418-7FA3-CC2C83ED9674

but in this case I couldn't even find my custom command in the commands list under "Customize".

I tried on two boxes, both running win7/64 and ArcMap w/ the most recent SP available installed.

Any clues?

Thanks a bunch
Alberto

Attachments

Outcomes