jread

Python script crashing with a fault on MaplexEngineLib.dll

Discussion created by jread on Feb 1, 2012
Latest reply on Feb 13, 2012 by jread
I am running a python script that exports a few thousand grid maps to .pdf format using Data Driven Pages.  The script works perfectly on the various grid map .mxds, except for one.  It randomly crashes after exporting a few hundred from a specific.mxd with the following windows error:

Problem signature:
  Problem Event Name: APPCRASH
  Application Name: python.exe
  Application Version: 0.0.0.0
  Application Timestamp: 4ba3e443
  Fault Module Name: MaplexEngineLib.dll
  Fault Module Version: 10.0.3.3600
  Fault Module Timestamp: 4e790ac9
  Exception Code: c0000005
  Exception Offset: 000eefd5
  OS Version: 6.1.7600.2.0.0.256.48
  Locale ID: 1033
  Additional Information 1: 0a9e
  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
  Additional Information 3: 0a9e
  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


I have run the script on two different machines and get this same error.  At first, I thought it might be a problem with the layer files used for the .mxd (they are all created using Maplex), however the EXACT same layer files are being used on a different .mxd (that has 4-times as many grids) and it runs perfectly.  Do you guys have any ideas of why this might be happening?  We have tried using Mxdoctor, etc. with no success.

Any suggestions would be most appreciated.

Attachments

Outcomes