sharkins

Buffer unionResults issue

Discussion created by sharkins on Jul 18, 2011
Latest reply on Aug 3, 2011 by rnarayanan-esristaff
I am attempting to use the geometry service to buffer two polygons (See attached SampleGeometry.json). The buffer operation works correctly. However, if I attempt to use the unionResults=true parameter it fails with a 400 error. The server log reports the following error

Method failed.HRESULT = 0x80040267 : This is a FACILITY_ITF error that is specific to the interface that returned this error. See the documentation of the interface that returned this error for information about this HRESULT.

I noted that this was similar to the post here http://forums.arcgis.com/threads/6085-geometryservice-buffer-union-results-error so I tried ensuring that all the rings were clockwise. (See attached SampleGeometry_allClockwise.json) but this still fails with the same error.

I then passed the geometry to the Geometry service's simplify operation prior to performing the buffer (See attached SampleGeometrySimplified.json) and this returns the correct results. Unfortunately my client is still using 9.3 and does not have access to the simplify operation. Can someone provide some information on why my SampleGeometry.json is failing when using unionResults=true and how the simplify operation is functioning internally to correctly format SampleGeometry in a way that works with unionResults=true?

Attachments

Outcomes