sbullimore

Problem using QtCreator with RHEL 6.5

Discussion created by sbullimore on Jun 6, 2014
Latest reply on Jun 6, 2014 by sbullimore
Hi

I'm trying to follow the instructions to set up ArcGIS SDK on 32 bit RHEL 6.5 which are given here: https://developers.arcgis.com/qt/guide/install-and-set-up-on-linux.htm. I have installed the latest version of QtCreator using the qt-creator-opensource-linux-x86-3.1.1.run file downloaded from http://qt-project.org/downloads. However, when I try to run QtCreator I get the following error:

Failed to load core: /home/user/Qt5.1.1/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: Cannot load library /home/user/Qt5.1.1/Tools/QtCreator/lib/qtcreator/plugins/QtProject/libCore.so: (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/user/Qt5.1.1/Tools/QtCreator/lib/qtcreator/plugins/QtProject/../.././libQt5CLucene.so.5)

I have searched forums and tried several approaches to fixing this. I have tried updating glibc using the following rpm: glibc-2.12-7.2.src.rpm. I have also tried updating gcc to version 4.7 by installing the Red Hat Developer Toolkit but I still do not have a version of libstdc++ containing GLIBCXX_3.4.15 (the highest version number I have is GLIBCXX_3.4.13).

The next thing I am considering trying is to build QtCreator from source. The problem I have is that this requires private headers from the Qt library (as explained here: http://doc.qt.digia.com/qtcreator-extending/getting-and-building.html) so Qt should be configured with the -developer-build option. However I do not want to rebuild the Qt libraries because I want to use the version supplied by ArcGIS.

I'd be grateful if anyone has suggestions as to the best thing to do.

Thank you!
SB

Outcomes