FSjoanlouie

Raster Calculator - Regression equation output not visible

Discussion created by FSjoanlouie on May 13, 2014
Hi all,
I am having trouble running a regression equation in Raster Calculator.  I have ArcMap 10.1 SP1.  Using the equation below, there is an output, but nothing is visible.  Does it have something to do with the messiness of my mixture of floating point and integer files?

Equation for Raster Calculator:
0.158544748 + (-0.422151664 * "lat") + (0.184392010 * "long") + (0.001245377 * "elev") + (-0.000000229 * "elevsq") + (1.121263096 * "parmat_al") + (1.003450855 * "parmat_gr") + (0.891204031 * "parmat_grhw") + (2.110142060 * "parmat_mix") + ( 0.000000000 *  "parmat_pooled") + (-0.544200414 * "sdi")


Output becomes:
floating point; 32-bit; 938.631325x938.631325
H:  3.40282e+038
L:  -3.40282e+038


Further information on each of my raster datasets:

lat = floating point; 32-bit; 30x30
H: 582090 | L:  45600

long = floating point; 32-bit; 30x30
H:  1.56678e+006 | L:  30840

elev = unsigned integer; 16-bit; 30x30
H:  3896 | L:  220

elevsq = signed integer; 32-bit; 30x30
H: 15178816 | L:  48400

parmat_al = unsigned integer; 8-bit; 30x30
(applies for all metrics preceded by "parmat_")

sdi = floating point; 32-bit; 938.631325x938.631325
H:  0.281522 | L:  0.00787991


I also tried adding one by one.  In this order, once I try to add a second "parmat" dataset, the output goes blank.  Separately, I tried adding ALL of the "parmat" datasets together, output is blank.

The "parmat" datasets were previously one vector (polygon) dataset.  I exported each type out to create their own raster datasets.  Should I do this differently?

Any suggestions or thoughts would be greatly, greatly appreciated.  Even if you need to point me to some manual that will tell me how to do it.  This type of analysis via ArcGIS is new to me, so I don't fully understand the "rules"...

Thank you!

Outcomes