talus-tech

NullReferenceException initializing LocalGeometryService

Discussion created by talus-tech on Mar 17, 2014
Latest reply on Mar 18, 2014 by talus-tech
We are having issues deploying to a test machine. Our application uses the 10.2 SDK WPF components and everything works fine on the development system.

However, if we add the "ArcGISRuntime10.2" folder from the deployment builder and execute the application we get a crash Inside the ArcGIS toolkit code as follows:

System.NullReferenceException: Object reference not set to an instance of an object.
   at ESRI.ArcGIS.Client.Local.LocalServer.InitializeDone(Exception error)
   at ESRI.ArcGIS.Client.Local.LocalServer.InitializeInternal()
   at ESRI.ArcGIS.Client.Local.LocalServer.InitializeAsync(Action callback)
   at ESRI.ArcGIS.Client.Local.LocalService.StartServiceInternal(QueryParameters serviceSpecificParams)
   at ESRI.ArcGIS.Client.Local.LocalGeometryService.StartGeometryServiceInternal()
   at ESRI.ArcGIS.Client.Local.LocalGeometryService.StartAsyncImpl()
   at ESRI.ArcGIS.Client.Local.LocalService.StartAsync()
   at ESRI.ArcGIS.Client.Local.LocalGeometryService.StartAsync()
   at ESRI.ArcGIS.Client.Local.LocalGeometryService.GetServiceAsyncInternal(Action`1 callback)
   at ESRI.ArcGIS.Client.Local.LocalGeometryService.GetServiceAsync(Action`1 callback)

Can anyone provide any assistance, we have tried countless things to attempt to fix this, but there is no logs, no intelligent output that would give us clues as to why the ArcGIS components are failing. We have tried 23-bit, 64-bit. No change and same exception. We have tried Basic/Standard licenses, no difference.

This occurs when we do:

LocalGeometryService.GetServiceAsync(lgs =>
{
    geometryService = new GeometryService() { Url = lgs.UrlGeometryService };
});

Outcomes