gissense

Updating feature's geometry ERRORS (10.2.0 - 10.2.1) ArcGIS Server, JAVA

Discussion created by gissense on Feb 14, 2014
Latest reply on Feb 14, 2014 by ldonahue
Hello,

I'm developing a SOE with JAVA.
I have a featureclass which must be updated.
I use the ITable.updateSearchedRows() method.
I'm developing in 10.2.1 and all goes well.

Now when I publish my SOE to a 10.2.0 ArcGIS Server, I'm getting a strange error:
AutomationException: Field is not editable.
I found out that it only occurs when updating the geometryfield (other fields succeed).
((ITable) fc).updateSearchedRows(qf, featureBuffer);


Also when I tried to create a workaround with an updateCursor, it still struggles on the geometry-field.
Example:
IFeatureCursor fcur = fc.IFeatureClass_update(qf, false);
IFeature feat2 = fcur.nextFeature(); 
feat2.setShapeByRef(feat2.getShapeCopy());
feat2.setValue(feat2.getFields().findField("FUNCTIONEEL_ID"), "testcollin1");
fcur.updateFeature(feat2);//errorline

AutomationException: Shape or row not found

I tried the IFeature.store() as well, but same result...

Both environments (10.2.0 and 10.2.1) have the same mapservice (published from the same mxd) and use the same DB-layers, so it's not a data thing.

Can it be that this is an issue in 10.2.0? And that it is being solved in 10.2.1?
Or is it just that a 10.2.1 JAR is not 100% working on a 10.2.0 environment?
I would like to know this before I might downgrade my dev.env. to the 10.2.0 version.

Regards,
Collin Kleiboer
GisSense

Outcomes