ranleu

Problem with CreateTin_3d in Python script

Discussion created by ranleu on Feb 3, 2014
Latest reply on Mar 11, 2014 by ranleu
Hi there, while working on a huge project with ArcGis 10 (ArcInfo license fully loaded) I needed to generate some TINs. So long story made short, prototype on Model Builder, Export to Python Script and of course it did not work. Search on the forum gave me some hints, but to my "surprise" not many threads on the subject. The hints where basically two:

- CreateTin has some issues working with projections ==> As far as I have tested it is not true, but with it in mind I edited my projection "grammar" and then it worked.
- CreateTin requires that at least one input is of type shape.Z ==> Also not true as far as I tested, but with it in mind I then found out that the <None> key word to designate the height field to be used, does not work and I do not seem to find anything wrong with my syntax. Here are the snipets:

This one does not work:
# arcpy.CreateTin_3d(qq, proyeccion,"F:\\FLOODS_USA\\ASSET_TRIAL\\VertFlood_08_9.shp <None> masspoints <None>", "CONSTRAINED_DELAUNAY")

Result:
ERROR 000800: The value is not a member of <None> | OBJECTID | STATIC_BFE | DEPTH | VELOCITY | BFE_REVERT | DEP_REVERT | X_Cent | Y_Cent | ORIG_FID.



This one works:
arcpy.CreateTin_3d(qq, proyeccion, "F:\\FLOODS_USA\\ASSET_TRIAL\\VertFlood_08_9.shp OBJECTID masspoints <None>", "CONSTRAINED_DELAUNAY")

Result: Exit code 0. It works

The only difference isthat I specified the OBJECTID, which is a field on my attribute table, and then it worked. Why is <None> not being accepted?

Any insights on this would be much appreciated as well as any other issue with TINs.

Outcomes