AnsweredAssumed Answered

Reverse Proxy - Web Adaptor - ArcGIS Server configuration

Question asked by masaaki_abeesrij-esridist Employee on Jan 27, 2014
Latest reply on Mar 28, 2016 by masaaki_abeesrij-esridist
Hello,

I have been trying to set up a Reverse Proxy(RP) - Web Adaptor(WA) - ArcGIS Server(AGS) configuration with each component set up on the seperation machines(3 teirs). And I'm using ArcGIS 10.2 for Server.(Also tried this with ArcGIS 10.1 SP1 for Server)

I did manage to make it work following the instruction of a technical article and even made it work with Apache as reverse proxy.

So,clients access to the http://RPserver/arcgis/rest/services,
the reverse proxy forwards the request to http://WAserver/arcgis/rest/services.
Then Web Adaptor forwards the request to http://AGSserver:6080/arcgis/rest/services.

This configuration worked successfully.
But when I changed the url of the access point from the clients, the url of the response messed up and couldn't make it work.
Specifically, I change the url of the access point to http://RPserver/accesspoint/rest/services.
When I access the http://RPserver/accesspoint/rest/services, I get the top page of the Services Directory. But the all links in the pages
has http://RPserver/arcgis/rest/services. Therefore, I get 500 errors.

I did set the WebContextURL as http://RPserver/accesspoint, but WebContextURL didn't work when having Web Adaptor in between Reverse proxy and ArcGIS Server.
(If web adaptor's instance name is accesspoint, it works.)


Has anybody tried this configuration before?

My only solution so far without changing the internal settings/files of ArcGIS for Server is to not use ArcGIS Web Adaptor and have the following configuration.

Clients - Reverse Proxy 1 - Reverse Proxy 2 - ArcGIS Server.

Although I have a solution, my ideal goal here is

1) I want to use Web Adaptor
2) I want to change the URLs of RP and Web Adaptor for security reasons.

Outcomes