bfeger88

Mosaic Dataset Issues

Discussion created by bfeger88 on Oct 28, 2013
Latest reply on Oct 31, 2013 by bfeger88
Hello All:

This is my first post on this forum and I would like to apologize in advance for it being a lengthy one. I also would like to apologize for the fact that my knowledge of GIS is not too vast. So, please bear with me.

Anyways, I am working on a project that requires an extensive amount of GIS work. Basically, the company I work for has been provided GIS data from a couple of different companies and have been asked to do a land impact analysis using their data. One piece of the data that was sent to us was imagery. One of the companies had aerial photography flown in Feb. 2013 of the project site. There is a massive amount of data, as it covers a large landbase. There was so much data that they had to send our company an external hard-drive that contained the information. We then placed the information on our network and sent the hard-drive back to them.

Within the main folder, there are four other folders. Two of the folders appear to contain the individual aerial photos in a .tif format. However, there seems to be other file types within these folders; such as .tif.aux.xml, .tif.xml, .tif.ovr, .rrd, and .aux. The third folder is a geodatabase folder and the final folder is an Overviews folder.

So, my work partner and I compiled all of the information that was provided into a .mxd project using ArcMap 10.2. When we brought the geodatabase file containing the imagery into the .mxd, the only thing we would see is a checkerboard pattern. So, we tried removing it from the .mxd and then brought it back in with no luck; the checkerboard pattern was still there. So, doing what any person does when they need answers to a problem, I googled "checkerboard pattern in ArcMap". I then began to learn about mosaic datasets and determined this is what I am dealing with. So, I have tried following advice in a couple of posts I have seen where people had similar issues. Mostly, I have tried to "repair mosaic dataset paths". I also ran the "analyze mosaic dataset", had some warnings and errors reported, and tried to fix them with no luck at all. Some of the Errors and Warnings that ArcMap shows are pixel type of the raster are outside the allowable range, the footprint of the mosaic dataset contains too many vertices, the overview raster dataset referenced has not been completely processed, and the mosic dataset item references files that are inaccessible.

One thing that I notice about my problem compared to similar problems I have read about is no matter what scale I am at in ArcMap, I cannot see the images. Some people said if they were at a large scale they could see the images, but not at a small scale; and some people had the opposite problem. I cannot see the images at all; just checkerboards. I should say, if I turn on the footprints and boundaries layers I can see those. Just no image. So, this indicates (to my understanding) that the mosaic dataset within the geodatabase file is not referencing the overviews nor the individual images. Am I understanding this correctly? It seems that I need to repair the paths that the data is being read from, but my attempts to do this have failed. So, when I run the "repair mosaic dataset paths" what file am I suppose to reference?

Again, I would like to apologize in advance for the length of this post. This is the first time I have dealt with mosaic datasets, I am quite confused about how they work/how to get them to work, and my bosses are counting on me to get this to work correctly. So, if anyone has any suggestions about how to fix my issue I am all ears and would greatly appreciate your input.

Thank you very much,

Bryan

Outcomes