AnsweredAssumed Answered

C# AddFeature

Question asked by richdjw on Sep 30, 2013
Latest reply on Feb 27, 2014 by JenLink
My setup
C# 4.0
Silverlight 5
ArcGIS 10.0

Issue:

I'm trying to use the REST API to add a feature.  I'm doing it this way because we want to be able to add a polygon without using a map.  When I post the JSON data we get a message back saying it was successful and we get the ObjectId back from the REST response.  However the attribute data that I attached to the request AND the polygon were not set at all.  Both have a <Null> value but I am able to verify the new record was inserted. 

Now when I run this same process on a the same feature class (sort of) but within our arcGIS 10.1 server it works perfect.  The record is inserted and all attribute and polygon data is visible in the newly inserted record.

As far as I can tell there is no difference between the 10.0 and 10.1 feature class other than the version of arcGIS.  The documentation that I found leads me to believe this should work on both 10.0 and 10.1.

Could it be that what I'm trying to achieve is only possible in 10.1.  From the documentation I found it looks like it should work on 10.0 and 10.1 but I could be mistaken.

I've compared the response/request using fiddler between using the webform addfeature and the rest call to add the feature and they are the same request/response messages.

Any suggestions are greatly appreciated as I've tried all I can think of.

Thanks,

Dean

Outcomes