IanGarnett

Message layers not displayed

Discussion created by IanGarnett on Jul 2, 2013
Latest reply on Jul 3, 2013 by IanGarnett
Hello,

I have been using ArcGIS runtime quite successfully to develop an application that makes use of military 2525C symbols. I recently tried to deploy to a customers hardware platform and found that nothing was being displayed on the map except the ESRI symbol + the navigation control. I later discovered that if I set the UseAcceleratedDisplay option to false I could get maps to be displayed but not symbols. I also tried moving all the message layers into an "AcceleratedDisplayLayers" but that had the same result. Even enabling the MGRS grid lines proved that the entire GroupLayer was not being displayed.

The hardware seems to meet the specs (Atom N2800 1.86 Ghz, 4 GB DDR3 + Intel GMA 3650 with 256 MB) and I also tried checking the render capability value as suggested in another thread using:

int tier = (System.Windows.Media.RenderCapability.Tier >> 16);


I have also tried running the application on other hardware platforms with success, one of them also uses an Atom Z530P.

I guess the obvious issue is the particular hardware setup, in which case it could be a deal breaker if we cannot display symbols.

Are there known limitations with particular hardware configurations? Also, are there other things I can try to get the symbols working?

Thanks in advance!

Outcomes